Lms-suit installation


Having problems installing lms-suit for LMS6002D.
After downloading from GIT hub (https://github.com/myriadrf/lms-suite), I have tried to follow the “Compilation guide windows” that was located lms-suit/docs.
Basically done the following steps:

  1. installed CMake

  2. installed Visual Studio (community)

  3. installed wxWidgets

  4. Build wxwidget library using VS, no errors.

  5. installed EZ-USB FX3 SDK

  6. extracted FFTW

  7. copied lms-suit folder from lms-suite-master\LMS6002D to c:\

  8. ran cmake, no errors reported after giving it correct FFTW path.

  9. opened up lms-suit.sln from the build directory and the tried to build it with VS. However here is where I get two errors, and I am not sure what I am missing, or which step that could have caused the errors.
    Both errors are in OpenGLGraph.cpp

Hoping anyone can help :slightly_smiling:

Found a solution. Seems that I used a version of vxwidgets that is to new.
So I reinstalled VS 2013 and wxwidget 3.0.2, and its working :slight_smile: