Limesuite Quick Test Fail Troubleshoot

Hi, I have another issue on LimeQuickTest. I have LimeSDR Mini, used to do some basic RF Experiment and found no signal coming form hardware. I tried to do LimeQuickTest and found this:

->Start time: Wed May 29 17:47:37 2024
->LimeSuite version: 23.11.0-g9dce3b6a

->Device: LimeSDR Mini, media=USB 3.0, module=FT601, addr=24607:1027, serial=1D90ED1A880390, HW=5, GW=2.2
Serial Number: 1D90ED1A880390
Chip temperature: 30 C

[ Clock Network Test ]
->REF clock test
Test results: 25282; 28212; 31035 - PASSED
->VCTCXO test
Results : 6711013 (min); 6711013 (max) - FAILED
->Clock Network Test FAILED

FPGA EEPROM not supported in v2

[ LMS7002M Test ]
->Perform Registers Test
->External Reset line test
Reg 0x20: Write value 0xFFFD, Read value 0xFFFD
Reg 0x20: value after reset 0x0FFFF
->LMS7002M Test PASSED

[ RF Loopback Test ]
->Configure LMS
->Run Tests (TX_2 → LNA_W):
CH0 (SXR=1000.0MHz, SXT=1005.0MHz): Result:(-26.1 dBFS, 5.00 MHz) - PASSED
->Run Tests (TX_1 → LNA_H):
CH0 (SXR=2100.0MHz, SXT=2105.0MHz): Result:(-19.0 dBFS, 5.00 MHz) - PASSED
->RF Loopback Test PASSED

=> Board tests FAILED <=

Elapsed time: 1.49 seconds

test result shown that my LimeSDR failed on VCTCXO Test and I inspected my board that R67 is still intact on my board. Any test do I need to verify/fix the problem?

hi @lawrence_ace24,

Even though VCTCXO test is failing you should be able to send and receive RF signals, especially when RF Loopback Test passes.

Why are you referring to R67? Have you done any modifications to your board?

Regarding VCTCXO test failure you can try few things:

  1. Try updating gateware by downloading lms7_trx_impl1.bit file and programming with LimeUtil --fpga=filename command where “filename” is full path to downloaded lms7_trx_impl1.bit file. After programming is completed re-plug your board and rerun LimeQuickTest, it should report GW=2.6.

  2. If gateware update does not help visually inspect the board. Look for IC11 component - this is the DAC which is responsible for tunning VCTCXO frequency and R72 resistor which connects DAC VOUT to VCO input of XO1. You can check board schematics from LimeSDR-Mini_2v2_Schematic_r0.PDF (I am assuming that you have LimeSDR-Mini v2.2 version).

hi @VytautasB ,

I tried the first solution by downloading lms7_trx_impl1.bit and programming it. After completed the programming , replug and rerun LimeQuickTest, it did report GW=2.6 but VCTCXO test still show failure.

Next I tried the 2nd solution by inspecting the R72 resistor with your provided schematic. I found R72 is missing on the board and I think I should have a replacement for it.

I am going to buy the replacement .May I know any place I should attention for beside R72 resistor?

Much appreciated for the support.

Just double check that your board version matches exactly schematic version. You should find it printed on silkscreen next to USB connector, because component numbering might be different on different versions.

If R72 is missing then obviously DAC output is not connected to VCO input of XO1 and VCTCXO test is failing because DAC cannot tune XO1 frequency.

Nothing special here, just look at the schematic and trace the path between IC11 VOUT and XO1 VCO. Look for any missing components, bad solder joints ect. Take in mind that some components are marked as NF (No Fit) in schematic, those are not fitted by default - ignore them.

Just to steer debugging process in right direction, have you done any modifications to your board?
Are you using external reference clock connected to J8 connector?