LimeSuite GUI on Linux

Hello everyone,

I’ve been trying to work on the LimeSDR mini and have gotten it up and running with srsLTE using some tutorials.

The problem I’m encountering is that when I run srsenb, I get expected output except for the following: [ERROR] Tx Calibration: MCU error 4 (SXT tune failed).

I read elsewhere that I should do the calibration from the LimeSuite GUI, however, I cannot seem to be able to run it. I built everything from source, but when i run the command it tells me command ‘LimeSuiteGUI’ not found. I followed the official guides:, and I can run other LimeSuite commands (like the quicktest).

Any suggestions?

Hello Wisaam,

Multiple problems that could have happened here and its hard to say without any logs/console outputs. If wxWidgets libraries weren’t found during cmake configuration, LimeSuiteGUI might have not even compiled. Could you post the output you are getting after running cmake?

Hello Garmus,

Thanks for your response. I eventually rebuilt LimeSuite, turns out I was missing the wxWidgets. The GUI appeared afterwards.

However, even after calibrating and tuning the SXT using the GUI, after running srsENB I still get the same error
[ERROR] Tx Calibration: MCU error 4 (SXT tune failed) .

I’ve tried multiple frequencies and configurations, in the GUI and the enb.config file.

Any suggestions?

Did you compile the latest master branch? There were some fixes specific to calibration.