Limesuite build errors on Ubuntu Mate 64-bit for PINE A64+

Trying to build 64-bit version of limesuite I hit errors, then I tried Novena-RF and also hit errors.
The 32-bit deb complains of a missing file but 64-bit is really needed.

Installed swig, python3-all, python3-all-dev, libsqlite3-0 and libsqplite3-dev.
Built and installed SoapySDR “git clone

Limesuite — “git clone
root@PINE64:/usr/src/LimeSuite/builddir# make
[ 1%] Building CXX object src/CMakeFiles/LimeSuite.dir/ConnectionNovenaRF7/ConnectionNovenaRF7Entry.cpp.o
/usr/src/LimeSuite/src/ConnectionNovenaRF7/ConnectionNovenaRF7Entry.cpp: In function ‘bool IsNovenaBoard()’:
/usr/src/LimeSuite/src/ConnectionNovenaRF7/ConnectionNovenaRF7Entry.cpp:36:30: error: elements of array ‘i2c_msg messages [2]’ have incomplete type
struct i2c_msg messages[2];
/usr/src/LimeSuite/src/ConnectionNovenaRF7/ConnectionNovenaRF7Entry.cpp:36:30: error: storage size of ‘messages’ isn’t known
/usr/src/LimeSuite/src/ConnectionNovenaRF7/ConnectionNovenaRF7Entry.cpp:47:25: error: ‘I2C_M_RD’ was not declared in this scope
messages[1].flags = I2C_M_RD;
src/CMakeFiles/LimeSuite.dir/build.make:662: recipe for target ‘src/CMakeFiles/LimeSuite.dir/ConnectionNovenaRF7/ConnectionNovenaRF7Entry.cpp.o’ failed
make[2]: *** [src/CMakeFiles/LimeSuite.dir/ConnectionNovenaRF7/ConnectionNovenaRF7Entry.cpp.o] Error 1
CMakeFiles/Makefile2:276: recipe for target ‘src/CMakeFiles/LimeSuite.dir/all’ failed
make[1]: *** [src/CMakeFiles/LimeSuite.dir/all] Error 2
Makefile:127: recipe for target ‘all’ failed
make: *** [all] Error 2

git clone
I tried building Novena-RF/driver/host/build#
CMakeFiles/NovenaRF.dir/flags.make:CXX_FLAGS = -fvisibility-inlines-hidden -std=c++11 -O3 -DNDEBUG -fPIC -Wall -Wextra -fvisibility=hidden -mfloat-abi=hard -mfpu=neon -std=gnu++11

removed -mfloat-abi=hard and -mfpu=neon which are ARM 7 CPU features.
Got a number of same -fpermissive errors.

[ 4%] Building CXX object CMakeFiles/NovenaRF.dir/Streaming.cpp.o
/usr/src/Novena-RF/driver/host/Streaming.cpp: In member function ‘virtual size_t NovenaRF::getStreamMTU(SoapySDR::Stream*) const’:
/usr/src/Novena-RF/driver/host/Streaming.cpp:130:19: error: cast from ‘SoapySDR::Stream’ to ‘int’ loses precision [-fpermissive]
if (int(stream) == SOAPY_SDR_RX)
/usr/src/Novena-RF/driver/host/Streaming.cpp:134:19: error: cast from ‘SoapySDR::Stream
’ to ‘int’ loses precision [-fpermissive]
if (int(stream) == SOAPY_SDR_TX)

error: ‘I2C_M_RD’ was not declared in this scope
messages[1].flags = I2C_M_RD;

Try installing libi2c-dev package.

Or just disable the ConnectionNovenaRF7 module if you don’t need it, by running “cmake … -DENABLE_NOVENARF7=OFF” inside the build directory.

Thanks ricardas … installing libi2c-dev fixed it.