LimeSDRUSB, GNU Radio, No full duplex in MIMO mode

Hello everyone, I am hoping someone can help.

I am trying to run my LimeSDR USB in MIMO mode, fullk duplex with GNU Radio. My flow graph is very simple, but I cant seem to get it to work. If I have the LimeSDR source in MIMO mode with both outputs connected to a LimeSDR sink MIMO mode (basically a simple throughput flow graph) and execute the flow graph, I can see the two inputs on an FFT, but if I connect a Spectrum Analyzer on the output, there is nothing there. I don’t see any errors in the GNU Radio window, it seems it should be working. Even stranger is if I take two UDP sources and UDP sinks (, different ports) and insert them in between the flow graph works great, it is only when I connect it directly, it does not work. I am attempting to make a coherent noise canceller with delays, and I had it working on an earlier version of GNU Radio, but the version I have not and any later version doesn’t work as described above. I have attempted many things, even setting the cal BW to 0, but nothing seems to make a difference besides injecting a UDP transport into the streams.

GNU Radio Version: 3.7.11
INFO: Connected Control port: LimeSDR-USB FW:4 HW:4 Protocol:1 GW:2.23

This problem just seems to be related to how GNU Radio is interfacing with the LimeSDR. Like I mentioned I had this working and I am not sure why it stopped working…

Any help would be greatly appreciated! Thank you!

In relation to this question, I remembered that I also upgraded the FX3 and GW just recently because LimeSuite told me my versions were out of date. My issue may be related to using a newer version of firmware, and I would like to regress to a older version and see if that makes any difference.

Could anyone send me a link to the previous versions of the FX3 and gate ware for a LimeSDR USB? I attempted to find it myself on github, but all I found was the latest versions and not any previous versions.

Also, any “how to” instructions would be appreciated. I did find instructions on the LimeSDR wiki, so I will attempt to use those if/when I find the older firmware files, but it is a little confusing.


I think here, maybe ?

That looks like it is it! Thank you for the link, I will give it a try and share with the group my findings. Cheers!

Well… one step forward, ten steps back. I flashed version 18.10 from the web site and tried my GNU radio flow graph, no change. Then I flashed it to 17.01 the baseline LimeSDR version, tried the GNU radio flow graph, no change. So, then I decided to go back to the latest version of gate ware and FX3 firmware, then LimeSuite locked up my PC and I had to reboot right in the middle of the flash, my LimeUSB is now bricked, I cannot connect to it over USB and the error LED on the unit is lit telling me it is bricked.

Anyone have a link now for how to unbrick my LimeSDR, or do I need to get it sent back to the factory?

I found the un-brick instructions and was successful. I am now back where I started.

Hi all, still working on this issue.

I found out that the issue may be related to the sample rate in my flow graph when I am using full duplex MIMO mode. If I set up my flow graph using 500ksps it works, then I can change it to 1Msps and it also works, however when I go up to 3 Msps or more, the flow graph crashes and will not start, if I reduce the sample rate (without changing anything else) it all works again, well sort of, about 3 Msps the output stops (nothing but a DC spike, no signal) but the flow graph works. Like in my previous post I have to use a UDP source/sink to get anything past 1 Msps to work (otherwise my flow graph crashes right away).

This is leading me to believe that may not be a GNU radio problem, but a limitation in using the full duplex, MIMO mode simultaneously. I have tried the same flow graph on 3 different computers, some slow, some high end, I have tried it with USB 2.0 and USB 3.0 with external power, no matter what, I am getting the same result with the higher sample rates.

Has anyone heard of any digital bandwidth limitations with the LimeSDR, using GNU Radio, full duplex in MIMO mode? I have tried the same setup in SISO mode and it works great up to high sample rates, but I am working with 2 channels for my application. If I disable the LimeSDR sink, the flow graph works great up to 30 Msps, so it seems to be related to the Tx capability.

I want to make sure it is not something that I am not doing correctly, if someone had some spare time and has a LimeSDR USB, I would appreciate it if you could you give it a try and see if you get the same results?

  • LimeSDR source, MIMO mode, calibration/analog/digital BW= 0, gain 60 dB
  • Both outputs (out0, out1) tied to LimeSDR sink and QT GUI Frequency Sink (2 input)
  • LimeSDR sink, MIMO mode, calibration/analog/digital BW= 0, gain 50 dB (have another SDR on one output to see if the output works)
  • Start out with a sample rate of 500 ksps and work up to 30 Msps.

Thanks for any help with this!