LimeSdrMini está travado!

Hello!
My LimeSdrMini crashed after a PC shutdown with a power failure at the exact moment I was loading the Example.ini file.
The clock indicator that was 40.000000Mhz, is now -0.00000001Mhz. Did the TCXO burn?
In the LimeQuickTest app, all icons are red.
Lime Suite Gui does not connect to LimeSdrMini.
What happened?
How to solve this?
Thank you all in advance.

Which example.ini, do you have a link?

INI file configurations are volatile and so I’m not sure how this could have caused a problem. As opposed to experiencing a power cut during firmware upgrade, which could.

Aqui está. Obrigado pela atenção!
https://wiki.myriadrf.org/LimeSDR-USB_Quick_Test

That procedure is for the larger LimeSDR USB board only.

Please use the LimeQuickTest utility instead and post the results.

The test at LimeQuickTest is all in red.

My guess is that the FPGA is not programmed and this got corrupted when you experienced a power failure. However, I cannot see how uploading an INI would cause this and would have thought it must have been mid-firmware upgrade.

@Zack anything to suggest?

Hi @titoaprendiz,

As @andrewback rightly mentioned, it looks like FPGA gateware is damaged. There is no possibility to damage FPGA gateware by uploading ini file.

Try to update board using LimeSuiteGUI and automatic update options.

@Zack
@andrewback
Thank you for the tips! Could you do this for me remotely through TeamViewer?
Or do you know someone who can do it?
This weekend can be at any time.

We don’t offer this kind of support I’m afraid and the process is very simple indeed.

Just enter at the prompt:

LimeUtil --update

Ok @andrewback
Thank you for the tips! I’ll try to do it here.
If I didn’t succeed, I’ll bother you a little more.
Hug!

I tried everything and nothing.
I’m in Brazil and bought LimeSdrMini directly from the CrowdSupply website: https://www.crowdsupply.com/lime-micro/limesdr-mini
It was delivered to the home of my friend who lives in the USA and came to Brazil and brought it to me.
I took a print of all the tabs of the Lime Suite Gui, so you can guide me better.
Check it out:

Uploading: v.png…

Everything I try to do in the Lime Suite Gui, it fails, and I can’t do anything.

Hi @titoaprendiz,

Set “Programming mode” to “Automatic” and try it again. Your computer have to be connected to the Internet during Automatic update.

image

@Andrewback
@Zack
Thanks for all the tips!
Now everything is working 100%.
The problem was solved with the command: LimeUtil --update
Thank you!

1 Like

2 Likes