LimeSDR USB v1.4 not detected by the PC in USB 3.0


I am the owner of a LimeSDR USB v1.4 board.
I have some very weird issues with the USB 3.0 communication.

If I insert the USB plug halfway into the USB port of my PC I can communicate with the SDR just fine - but I am limited to USB 2.0 speeds. As soon as I insert the USB plug all the way (so that it makes contact with the USB 3.0 pins of the connector) the SDR is no longer being detected by the PC. I already checked all the relevant traces for shorts - there aren’t any. The LEDs all light up just fine, there is just no USB communication possible with the board (not even USB 2.0 with all pins making contact).

I ran LimeQuickTest in USB 2.0 mode, here is what that prints out:

->Start time: Sun Oct  3 22:19:37 2021
->LimeSuite version: 20.10.0-ga45e482d

->Device: LimeSDR-USB, media=USB 2.0, module=FX3, addr=1d50:6108, serial=0009081C05C4382C, HW=4, GW=2.23
Warning: USB3 not available
  Serial Number: 0009081C05C4382C
 Chip temperature: 23 C

[ Clock Network Test ]
->FX3 GPIF clock test
  Test results: 25298; 29054; 32810 - PASSED
->Si5351C test
  CLK0: 17554 / 17554 - PASSED
  CLK1: 17554 / 17554 - PASSED
  CLK2: 17554 / 17554 - PASSED
  CLK3: 17554 / 17554 - PASSED
  CLK4: 17554 / 17554 - PASSED
  CLK5: 17554 / 17554 - PASSED
  CLK6: 17554 / 17554 - PASSED
->ADF4002 Test
  Result: 10 - PASSED
->VCTCXO test
  Results : 5112945 (min); 5113093 (max) - PASSED
->Clock Network Test PASSED

->Read data: 13 01 1C 13 01 1C 02

[ LMS7002M Test ]
->Perform Registers Test
->External Reset line test
  Reg 0x20: Write value 0xFFFD, Read value 0xFFFD
  Reg 0x20: value after reset 0x0FFFF
->LMS7002M Test PASSED

[ RF Loopback Test ]
Note: The test should be run without anything connected to RF ports
->Configure LMS
->Run Tests (TX_2-> LNA_L):
  CH0 (SXR=800.0MHz, SXT=805.0MHz): Result:(-14.4 dBFS, 5.00 MHz) - PASSED
  CH1 (SXR=800.0MHz, SXT=805.0MHz): Result:(-16.3 dBFS, 5.00 MHz) - PASSED
->Run Tests (TX_1 -> LNA_W):
  CH0 (SXR=1800.0MHz, SXT=1805.0MHz): Result:(-14.6 dBFS, 5.00 MHz) - PASSED
  CH1 (SXR=1800.0MHz, SXT=1805.0MHz): Result:(-16.7 dBFS, 5.00 MHz) - PASSED
->Run Tests (TX_2-> LNA_H):
  CH0 (SXR=2500.0MHz, SXT=2505.0MHz): Result:(-16.0 dBFS, 5.00 MHz) - PASSED
  CH1 (SXR=2500.0MHz, SXT=2505.0MHz): Result:(-14.0 dBFS, 5.00 MHz) - PASSED
->RF Loopback Test PASSED

=> Board tests PASSED <=

Elapsed time: 2.12 seconds

I repeated everything on a second PC - everything is the same. I also can’t see anything in the dmesg logs that would be relevant.

Does anyone know what else I could try? To me it sounds like the USB controller might have died in which case I would have to buy a new board.

Many thanks,


The are four logical places for a fault like that:

  • Power issue (I unplug every USB device I can when troubleshooting to minimise the load, or voltage drop, on the Power Supply Unit in the PC. In an attempt to maximise the power available, which still may not be enough with some badly underspeced PSU’s)
  • Damaged USB cable (With USB 2.0 four wires are needed, USB 3.0 adds an additional five wires, for a total of nine). So by partially plugging the cable in you are probably only accessing the USB 2.0 pins in the cable, which may mean that any of the other 5 wires or pins are short circuited.
  • faulty USB port (or controller chip) in the PC (easy test is to try the device in EVERY USB port in the PC, not all ports are the same, not all use the same controller chips and sometimes all ports do not even use the same output section of the power supply unit. Or you could try in USB ports in two different makes and models of PC’s - that way you are hopefully testing against two different PSU’s and two different USB controller chips).
  • faulty device

If I had to bet on one I’d pick the USB cable. And the reason I would pick that is because USB cables are designed to be a consumable part which will eventually fail (wear down) before the ports, because it is an easier part to replace.

@dk5av If you haven’t already could you try a different USB port and/or cable. Also as @mzs suggests may be worth minimising load on the PSU from other peripherals.

Also tagging @Zack to see if he has any further suggestions.

Hi @dk5av,

Do you have plug or socket version? It looks like you have plug version from what I read. In any case just inspect USB connector pin soldering. Otherwise @andrewback and @mzs covered everything I think.

Hi all,

many thanks for all the replies.

Yup, good point. I already checked that and it’s receiving power properly. I even tried adding a PSU into the additional DC jack, same result.

Yep, another good point. I tried three different USB 3.0 cables as well as plugging the SDR directly into the PC. Everything ends up with the same result. USB 2.0 works fine if I insert it halfway and if I insert it all the way it’s not detected at all. There are no shorts between any of the connections.

I already ruled that out, I tried all USB ports on my Desktop and on my Laptop. Both are using totally different USB chipsets. I even tried it on Windows with the same result.

All tests were done with only the SDR connected to the PC. In case of the desktop the only other I had connected was a keyboard and a mouse. On the laptop it was the only USB device.

I indeed have the plug version. I checked all the traces carefully and they are all making contact properly. I even measured for continuity from the USB port to C270 and C271 as well as between the remaining two traces from the USB port to the fuse IC. Everything is making good contact.

I’m starting to think that the USB controller (CYUSB3014-BZXC) is faulty in this case. The board is about 18 months old and it worked perfectly fine in USB 3.0 mode up until now.

Do you have any other suggestions or ideas of what else I could try?