LimeSDR USB Gateware Update Oddities : Version 257?

#1

Problem

My LimeSDR is being very adamant that it doesn’t want to do work

Description

I’ve had many of the problems descriped in other threads about firmware updates not working as hoped. But I couldn’t find someone else asking about odd gateware revision numbers like I’m having :

When I flash my LimeSDR, and reconnect to it, I get a warning for a version mismatch. Sometimes, rather than having version 0 revision 0, I’ll end up having revision 0 of version 257, which is odd considering it’s looking for version 2 revision 12.

What I’ve tried

Running all sorts of orders of flashing from the LimeSuite GUI and using LimeUtil --update, --fw and --fpga. Up till now, I have only managed a couple times to obtain a version match, but that would always only last for a single boot.

Any idea what I should try now ? I’m starting to feel sad about this poor little brick sitting on my desk…

LimeSDR gives Gateware version 0 / 257 when cold, is OK when warmed up
#2

Perhaps your USB port does not give sufficient and stable power to the device.

1 Like
#3

@vPAvital,

And the only thing I would add to the discussion from Alex is that the LimeSDR supports a 5V power supply input on a power coaxial connector (not RF coaxial connector) from an external power supply (should be capable of 2A at 5VDC) such that you’re not drawing power from your USB 3.0 connection from your PC.

One other thing you can try that I HAVE to do with smaller PCs or tablets is to buy a powered USB 3.0 hub and plug that into your PC and attach your Lime onto the hub port of choice (mine is a 4 port and the Lime is not picky). THAT works because it isolates your PC from the LimeSDR for power, but provides the data the same way.

Give either a try and then report back - 73 de Marty, KN0CK

#4

The spec is 6V minimum for the external power supply (check the silkscreen on the PCB). With 5V external supply you may expect issues as well.
Check Figure 3 here:
http://wiki.myriadrf.org/LimeSDR-USB_hardware_description
As well as here:
http://wiki.myriadrf.org/LimeSDR-USB_hardware_description#Power_distribution

Correct, but it may limit a USB throughput if there are more devices connected to the USB hub. But if you need a small USB data bandwidth then yes, this may be a choice.

#5

Hello, thanks everyone for your help,

I’ve just tried plugging the LimeSDR to a PSU (set it to 10V, the Lime seems to be drawing between 0.3 and 0.4 Amps according to the PSU). I’m still experiencing the same issues, with the gateware version dancing between 0 and 257.

I’ve also tried using an older image (v2 r8), but the result is still the same.

I’m mostly getting version 0 revision 0 now.

Any other ideas I should try ? I haven’t played with the jumpers much yet, maybe something there ?

#6

What is current settings in your PSU? Maybe current is limited?

#7

Give it a go in a USB 2 port (as well as external power supply) and see if you have the same issues.

#8

Problem got weirder

Now, I can get the proper version of the firmware when I check it with LimeUtil --make, but that doesn’t last : only once per reset (or twice on occasions) does the Lime display the proper version.

Here’s the output of my GNU Radio block trying to use the LimeSDR:

linux; GNU C++ version 6.2.0 20161027; Boost_106200; UHD_003.009.005-0-unknown  
gr-osmosdr 0.1.4 (0.1.4) gnuradio 3.7.10  
built-in source types: file osmosdr fcd rtl rtl_tcp uhd miri hackrf bladerf rfspace airspy soapy redpitaya    
[INFO] Make connection: 'LimeSDR-USB [USB 3.0] 9061C02CF0D21'  
[INFO] Device name: LimeSDR-USB  
[INFO] Reference: 30.72 MHz  
[INFO] Init LMS7002M(0)   
[INFO] Ver=7, Rev=1, Mask=1  
FATAL: UploadAll() failed

What is your current settings in your PSU?

My PSU is set to deliver up to 2A at 10V (this one can’t do better)

Give it a go in a USB2 port

Will try (thank god my Linux setup is on an external SSD, my standard laptop only has USB3 ports (first world problems)

#9

@Zack, any more suggestions to try or should we arrange an RMA?

#10

RMA please.