LimeSDR osmo-trx no work


#84

https://osmocom.org/issues/2723
reclassifying as “Low” as we are working on osmo-bts-lms to address this.


#85

@cswiger - great job on the docker and figuring this out! I spun up your image and cellphones attach fine to the network, SMS messaging works, and GPRS works as well. Trying to figure out how to enable local voice calling (busy signal for now). Thanks a lot for sharing your work!


#86

Appreciate the feedback.
Voice calling previously, with nitb, needed LCR Linux Call Router with some hacks to work (use old version, change MNCC version) and I could not get a package built for deb, etc. Going forward there is a sip connector which I have not figured out how to use (with an existing Asterisk running that has a pstn gateway already setup).

I’d like a pointer to some instructions on how to setup voice calls with the latest osmo-bsc, hlr, etc in place of osmo-nitb.


#87

Thanks a bunch for your work!

I just wanted to test your container with my LimeSDR on an Ubuntu 18.04 machine, but I’m seeing a couple of strange things:

  • screen -r doesn’t show a screen with the name “trx”
  • The bts screen outputs <000b> trx_if.c:182 No response from transceiver for phy0.0 (CMD POWEROFF)
  • Attaching the container and executing LimeUtil returns Illegal instruction (core dumped)

I assume that the first two issues can be solved by fixing the last one, but do you have any idea what’s going wrong?


#88

Afraid I am stumped on the “Illegal Instruction” from LimeUtil - you can run in / (root of container with all the cfg files) - osmo-trx and that will probably fail also, hence no screen named ‘trx’ (the screen is started, then osmo-trx fails and exits it sounds like).


#89

Yeah, that is exactly what happens. I was able to build LimeSuite by myself and replace the bins, which helped fix the command. But osmo-trx is still having the “Illegal instruction” issue. I’ve also tried building it myself, but ran into a couple of dependency issues.

Will try it again later — thanks for your help!


#90

@cswiger - got local calling working fine now using that old fork of LCR you recommended! Added interface.conf, options.conf, routing.conf with configs per https://osmocom.org/projects/cellular-infrastructure/wiki/SDR_OsmoTRX_network_from_scratch#routingconf and she is happy! :slight_smile: Calls connect and audio is clear both ways.

Occasionally I get intermittent timeouts on my Lime:
Mon Jun 4 17:17:48 2018 DMAIN <0000> Logger.cpp:53 [tid=140388617557760] UHD: Receive timed out
causing transceiver to basically die. But I am not using any Ext Clock Ref may be that’s why… I’ll try running it with external GPSDO and see if that helps with stability. Thanks again for your solid pointers!


#91

@4m4rOk – I would try without screens. Start the container in the docker and then open 6 terminals. In each terminal run docker exec -it osmogsm /bin/bash to get into it. Then run each component in its own terminal so that you see what’s going on:
term1: /usr/bin/osmo-nitb -m -P
term2: /usr/bin/osmo-bts-trx
term3: /usr/bin/osmo-trx
you can actually stop here for now and see what happens with osmo-trx.


#92

Hey @5harp1e, thanks for the advice! I’ve already done so and am getting the “Illegal Instruction” error when osmo-trx tries to interact with the Lime.


#93

Hello

regarding the osmocom stack, do we need to build from source or can we use package managers ?

how did you guys install it, aside from the attached docker.

Thanks


#95

HEY cswiger! working on a cool project with limesdr wondering if you would be willing to help point me in the right direction?


#96

If it is something I might know off the top of my head - not doing any research in sdr at the moment.


#97

I’m trying to create a kind of wireless firewall using a Nitb as a starting point, I have 2 limesdr mini’s and have successfully got a GSM900 system up and running, but when I tried to change to 1900 for US phones it wouldn’t startup. So I have abandoned that approach and have been working on OAI and running a LTE nitb which I will hopefully get working soon. I just wanted to reach out to you as I see you on forums quite a bit. I’m just working on one step at a time, but not really sure if I am heading in the right direction


#98

did you config correctly the band on the .conf file ?


#99

I followed this tutorial for GSM
https://osmocom.org/projects/cellular-infrastructure/wiki/Osmocom_New_Splits_(BSC_MGW_HLR_MSC)
and changed osmo-bsc.cfg from band GSM900 to GSM1900 but it wouldn’t start. As far as the OAI method, still working on it, will hopefully be changing band7 per tutorial to band 12


#100

@brandonrains please stop cross-posting! This is really unhelpful. If you have a problem with a particular thing post about it in one place and one place only. I’ve replied to your thread here:


#101

Thanks for the help! I’ll check it out!


#102

I changed the band PCS1900 in osmo-bsc.cfg, also the band to PCS1900 under the bts 0 heading in osmo-bts-trx.cfg. And it kept crashing on me. It gave the following error:
Please do not use legacy config ‘mgw endpoint-range’ (the range can no longer be defined by the MGCP client)
20190118144951103 DLGLOBAL <0013> telnet_interface.c:104 Available via telnet 127.0.0.1 4242
20190118144951103 DNM <0004> osmo_bsc_main.c:420 GSM1900 channel must be between 512-810.
20190118144951103 DNM <0004> osmo_bsc_main.c:519 Error bootstrapping BTS
Bootstrapping the network failed. exiting.


#103

Looks like the ARFCN (channel number) is not valid. You can find a list of valid channels here:

http://niviuk.free.fr/gsm_arfcn.php


#104

Thanks andrew! I’ll check it out!