LimeSDR Mini - USB errors, LEDs off and JTAG issues

My LimeSDR Mini (v1.2) seems to have suffered a failure.

I had it running successfully for a few hours with CubicSDR. I paused the radio receive process, then came back to find the LimeSDR’s LEDs were off and CubicSDR had crashed.

I reconnected the LimeSDR - the LEDs remained off.

I tried LimeQuickTest – this reports “TransferPacket: Read failed” and “TransferPacket: Write failed” errors.

I’ve since bought a USB Blaster and set it up per this article:
And used Quartus Prime Programmer to reprogram the gateware with the image from:

If I load the HW1.2 POF file, the behaviour of the board doesn’t change - when plugged into the USB port the LEDs stay off.
If I load the HW1.2 SOF file, the LEDs light up and the board works okay. When unplugged from the USB port and reconnected, it goes back to the no-LEDs and USB-errors behaviour.

… Well, I say it works okay – I just tried again and I get a failure on the RF loopback test:

->Start time: Fri Mar 19 17:02:53 2021
->LimeSuite version: 20.10.0-myriadrf2~focal

->Device: LimeSDR Mini, media=USB 3.0, module=FT601, addr=24607:1027, serial=1D42598C70F559, HW=2, GW=1.30
  Serial Number: 1D42598C70F559
 Chip temperature: 34 C

[ Clock Network Test ]
->REF clock test
  Test results: 38098; 51295; 64492 - PASSED
->VCTCXO test
  Results : 6711046 (min); 6711199 (max) - PASSED
->Clock Network Test PASSED

->Read data: 12 07 1B 12 07 1B 02

[ LMS7002M Test ]
->Perform Registers Test
->External Reset line test
  Reg 0x20: Write value 0xFFFD, Read value 0xFFFD
  Reg 0x20: value after reset 0x0FFFF
->LMS7002M Test PASSED

[ RF Loopback Test ]
->Configure LMS
->Run Tests (TX_2 -> LNA_W):
  CH0 (SXR=1000.0MHz, SXT=1005.0MHz): Result:(-66.6 dBFS, 5.00 MHz) - FAILED
->Run Tests (TX_1 -> LNA_H):
  CH0 (SXR=2100.0MHz, SXT=2105.0MHz): Result:(-55.2 dBFS, 5.00 MHz) - FAILED
->RF Loopback Test FAILED

=> Board tests FAILED <=

Elapsed time: 2.49 seconds

Is there anything else I can try to fix this board – or if not, how can I get it replaced?


Tagging @Zack.