LimeSDR Mini - Partially DEAD please help 😭

my mini is not recognised anymore by the PC, no activity when you plugin USB

the LED just lights up orange and stays like that

I am suspecting an issue with the FTDI USB chip. I also notice the USB port it used to reside in is dead too, not even power so I am suspecting a short might have happened

has anyone replaced the FTDI chip ? it is available from most distributors, going to be a challenge at 0.4mm pitch

can anyone help with reading resistance values on USB pins…I see some inconsitancees

On the usb connector, whilst holding board with USB facing up, 1st pin from left (SSTX+)…to ground is only 16ohms…all others(except grounds) are in the Kohms range

other than that all voltages seem to be there around the regulators

A day later and its still the same… anyone had this problem?

Ive had trouble with usb extenders causing no detection. Plugging directly solved it.

I have tried directly also, on 4 different PC’s now, the lime is dead and getting support, paid or otherwise seems impossible, this will be a deciding factor on my next purchase

Have you tried to flash Gateware using limesuite?

I have tried everything, the USB device is not detected, both in windows and linux

The USB port it was in at the time has also died, my suspicion is that the FTDI chip is dead

The only other thing to try is flash by JTAG.

Isn’t JTAG for FPGA ? Wouldn’t the ftdi usb chip enumerate anyway if it was from fpga

it probably is ftdi chip as your usb port died also. Was just thinking that something less drastic could be done.

yes i think it is the ftdi and i can probably source this chip and replace, but before i would like to know:
(1) possible to test/compare resistance values of USB connector pins to be sure its the chip
(2) see if anyone else has had this issue and if they replaced the chip and resolved it
(3) does the ftdi work “out of the box” once replaced or does it need some firmware

Hi @9H1LO,

It looks like you are using Windows. What Device manager says?
You can try FTDI configuration tool:
https://www.ftdichip.com/Support/Utilities/FT600ChipConfigurationProgUtility_v1.3.0.2.zip

I tried both windows and linux, windows device manager doesn’t even realise something was plugged in, and neither does ubuntu lsusb

i had also tried FTDI tool as i know it from other projects, and result is:

No device is connected to the machine!
Please connect a device!

I think the FTDI chip is dead

Check USB connector. It looks OK from the photo, but worth checking.

Usb connector pins to back contacts are fine.1st pin from left (SSTX+)…to ground is only 16ohms…all others(except grounds) are in the Kohms range

considering this has cost nearly $200 and support response seems non-existent

Crowd Supply brushing me off onto this forum saying 3 months warranty, when legally selling in the EU should be covered by 24 months, I believe I was supplied by a faulty device as this issue first started with signals disappearing then USB going dead, shame I left it on the shelf for a year…

anyway i am going to order a replacement ftdi chip and hopefully will repair it

going forward I have purchased an adalm pluto, order Friday from mouser in Texas —> delivered in Malta, Europe by Monday (the lime took 2 months!) and performance already looks better,and signals remain after 10 minutes unlike the Lime

So I will be recommending the Pluto over the Lime to any local hams