Limesdr-mini osmo-trx-lms DDEV <0002> error


#1

Hello, I’m using builded from sources osmo-trx-lms. Some time after the start (random time, it could be a minute or a few seconds) trx starts to log errors. Base station stops working. Has anyone had a similar problem? I do not know how to solve it.

My configs:
osmo-trx-lms.cfg
openbsc.cfg (osmo-nitb)
osmo-bts-trx

I also tried to use these configs: https://github.com/myriadrf/cellular-network-configs/tree/master/osmocom
The same problem


#2

When this happens it is usually something interrupting the transceiver and causing the stream of samples to/from the SDR to be interrupted. Try to make sure you are running no other software which might cause OsmoTRX scheduling delays and generally do anything you can to reduce latency, including making sure that you do not have a dynamic CPU governor which adjusts processor speed based on load and temperature etc.


#3

thanks for reply. Have tested lime mini + orange pi zero + openbts and osmo-trx-lms builded from source. The same situation: base station stops working in a minute


#4

You may want to check this thread on the Osmocom mailing list:

http://lists.osmocom.org/pipermail/openbsc/2019-January/012713.html


#5

Yes, it works now! Setting realtime priority to osmo-trx and cooling orange pi zero solve the problem. LimeSDR Mini with orange pi zero and OpenBTS works pretty fine together

%D0%B8%D0%B7%D0%BE%D0%B1%D1%80%D0%B0%D0%B6%D0%B5%D0%BD%D0%B8%D0%B5


#6

Excellent, that is good to hear!