LimeSDR-mini Gnuradio Glitches

Hi all,

I am trying to perform qpsk transmission using the limesdr-mini, and unfortunately I’m stuck. I based my flowgraph on gr-tutorial and replaced the “channel” with a LimeSDR-mini with the TX connected to the RX via an RF coaxial cable with 60-dB worth of attenuation. I have tried more or less the same flowgraph with both the USRP b200mini and the ADALM-Pluto, and I can get a very nice constellation. My flowgraph is shown below.

and here is the performance I am getting (top: before Polyphase, bottom: after Polyphase)

I can get more distinct constellation points if I increase the number of samples per symbol, however the constellation diagram still looks very noisy compared to my other SDRs. In the time domain, I get this plot with samples/symbol equal to 32 (top: output of modulator, bottom: output of Lime Source).

There are obvious glitches in the signal which suggest to me (as a non-expert) that it is probably digital. I would appreciate some suggestions on how to proceed with debugging. I like the form factor and pricing of the limesdr-mini so I would really like to get it working properly.

best regards,

Looks like distorted signal, try to reduce gains.

thanks for your input. I tried reducing both TX and RX gain by 10 dB, but the glitches are as bad as ever.

Try to reduce them more until constelation won’t be limited by this square.

I tried reducing the gains significantly, but the glitches were still observable. It got to the point where the signal quantisation was very noticeable.


Why does the modulator output has values outside [-1:1] range, or is it just that the graph looks like this?

RX Looks like dropped packets or rx digital dc correction. It might also be some kind of intermodulation of the Rx and Tx PLLs as they are set to identical center frequency, try setting receiver center frequency to some other nearby value and use NCO to shift back to your desired frequency.

Hi Ricardas,


this solved the problem. I think the signal excursion was due to the rrc filter in the constellation modulator. I took the block directly from gr-tutorial, but I didn’t consider clipping at the DAC.


so you were right, thanks for the help.

best regards,