LimeSDR Mini carrier not supressed when using ext. clock


I installed an external reference (10MHz, rectangular signal) on my LimeSDR Mini.
After installing I tested it using GNURadio, SDRAngel and SDR-Console.
It transmits an receives fine but when using GNURadio, the carrier is not suppressed. (SDR-Console seems to suppress the carrier). Also when using SDRAngel it doesn’t work and keeps throwing these errors:

(W) SampleSourceFifo::write: overrrun (read too slow) dropping 1280000 samples
(W) SampleSourceFifo::write: underrun (write too slow) using 1280000 old samples

The log of my GNURadio has no obvious errors (as far as I cen tell):

Reference clock 10,00 MHz
Using device: LimeSDR-Mini(SERIALNUMBER HERE) GW: 1.30 FW: 6

INFO: device_handler::enable_channels(): SISO CH0 set for device number 0.
INFO: device_handler::set_samp_rate(): set sampling rate: 6.4 MS/s.
INFO: device_handler::set_rf_freq(): RF frequency set [TX]: 435 MHz.
INFO: device_handler::set_analog_filter(): Filter calibrated. Filter order-4th, filter bandwidth set to 5 MHz.Real pole 1st order filter set to 2.5 MHz. Preemphasis filter not active
TX LPF configured
INFO: device_handler::set_digital_filter(): digital filter CH0 [TX]: 2 MHz.
INFO: device_handler::set_gain(): set gain [TX] CH0: 40 dB.
INFO: device_handler::set_antenna(): Selected TX path: Band 2
CH0 antenna set [TX]: BAND2.
INFO: device_handler::calibrate(): Tx calibration finished
INFO: sink_impl::init_stream(): sink channel 0 (device nr. 0) stream setup done.

So my question is which setting I forgot to change or where my setup has an error.
I also tried using the NCO as an offset, but the carrier on the RF frequency still exists.
I tested the Lime before the modification and it passed the selftest. After swapping the resistor it didn’t pass because I replaced the oscillator with an external one

TLDR; Using an external oscillator just seem to work in SDR-Console, SDRAngel doesn’t work at all and GNURadio doesn’t suppress the carrier

Do you have any ideas?

@sigrokBlack For your dropped samples take a look at… There is multiple USB issues resolved in the thread. Sorry, can’t help with external clock.

Hi, thank you for your answer. The SDR works great on my usb ports when using the internal oscillator. So this issue seems to be in conjunction with an external oscillator. I also realized that SDRAngel has another problem. The actual bandwidth of an signal much high as it should be. Setting the ssb modulator zo 2.8 KHz results in a 28kHZ signal so there seems to be a bigger problem with the lime and sdrangel going on.

But the key problem is still present: The carrier wave is not suppressed.

@sigrokBlack SDRAngel is a little glitchy. It doesn’t seem to support two radios in one Lime A at once and sets the first to the same tune as the second. I was unable to monitor two bands as a result. Maybe ok for simplex or full-duplex on same band. It doesn’t always seem to take setting changes all the time, some things seem to reset too. I toggle the “DC” block button (in SDRAngel) and it seems to get the settings to take. I was really only responding to your dropped packets USB. It seems you need a lot of CPU to use large bandwidth and to verify the bus speed (at least when using SDRAngel).

Hi, Thank you for your help. I’ll try to fiddle around with SDRAngel and regarding this issue I’ll probably go to the SDRAngel forum. I can confirm that SDRAngel crashes sometimes when using the limesdr. I tried on multiple machines which al had the same issues. So I think regarding the bandwidth error / unsuppressed carrier that there is a problem in the LimeSDR code of SDRAngel.

So the only thing in question is why the carrier is not suppressed in gnuradio?

After some fiddling I got SDRAngel to use the correct bandwidth. @Grimmace There was an bandwidth mismatch which as you described was too much for my cpu. One problem sorted out, yeah!.
Just the DC spike to get rid of

1 Like