LimeSDR-Mini and osmo-trx not stable with OpenBTS

Why do I still have this error with osmo-trx for openbts?

I tried with and without uhd, with and without soapyuhd, with osmo-trx-limesdr.cfg -f and default.cfg -f … I always have these errors.

I tried in usb 2.0 and usb 3.0 … I still have these errors.

It seems a bit more stable with an installation with uhd and running osmo-trx-lms -C default.cfg -f

But still these insuoportable errors.

Do you know what to do to stabilize the operation and not have these errors?

Can this help someone to help me :slight_smile:

[FATAL] [UHDSoapyDevice] Rx Calibration: Bandwidth out of range, available range: from 2.5 to 120 MHz

I have also the same problem? how did you solve the problem ?

The same problem with osmo-trx-lms and osmo-nitb

@dast and @g0dfuzz3r Have you fixed the problem ?

Yes, you just use compile or install the last osmo-trx and use osmo-trx-lms not osmo-trx-uhd. No need to install soapyUHD

Thank you very much for your answer.

I had tried with osmo-trx-lms without UHD and had the same problem.

What version of VMware are you using?

How long osmoTRX-lms work.

Don’t use vmware, it has any problem of synchronization indeed about usb on limesdrmini! it’s could run more than one day!!! I’m using two motorola phone with arduino and ULN and it’s run correctly also. but it use osmocom firmware not osmo-trx-lms



1 Like