LIMESDR - How to change the bandwidth of the signal (Sweep)?


I’ve been trying to change the bandwidth of the signal I am Transmitting but it seems that it doesn’t exceeds the 200 KHz margin (spectrum analyzer). I have literally tried every configuration, that my knowledge is capable of. The following config is the one I have managed to have some kind of variation by changing the amplitude of the source signal. Knowing that the LimeSDR is capable of achieving 60 MHz bandwidth.

I would really appreciate any tips to increase the bandwidth and the basis of it. Actually, the results I get on Gnuradio’s Frequency Sink doesn’t match with the ones I get on the spectrum analyzer, in terms of frequency magnitudes.

Below I post one of my recent config.

Thank you.

Your signal is not 200 KHz wide, whatever gnuradio says you are not getting correct values for bandwitdh unless you adjust bandwidth QT GUI Sink block parameter correctly ( sample rate of your signal, 4M above, 20.1689M / 5 below)

I suggest you the gnuradio tutorials as i can see many other basic things wrong in your flowgraph.

1 Like

The signal is not 200 KHz wide but the bandwidth of my sawtooth sweep is. And I need it to be wider.
The sample rate is wrong, yes. When I took this print I was making some tests, but notice that either way I resample it to be in the same rate as Tx.

Do you mean the pulse width you see in the spectrum analizer? In theory it should have 0 width and should be slowly bouncing around 2GHz, of course you can apply some easy tricks:

Reduce FFT size to 64 or 32 and use blackman-harris window.

Another option would be reduce the spectral purity of the vco ouput by multiplying the output by a real cosine signal of frequency 50 KHz ( play with this value) and maintain amplitude to 1 and offset to 0 too.

I don’t know why you want this, but this is not practical.

1 Like