LimeSDR hardware problem: USB controller?

#1

Hi,

I am having issues with my LimeSDR USB (v1.4s).

When I first got it it was working fine, and has performed correctly for the next months or so. Then, it started giving me symptoms such as:

  • not replying correctly to any commands (the infamous " Read ( 64 bytes ) failed")
  • flashing firmwares not working (incorrect gateware version 0 rev 0 upon completion)

It was random at first, and disconnecting/reconnecting power supply would fix it, then it got worse and worse to the point that now, my LimeSDR has been completely dead for months. I tried changing OS, cables, power supply, firmware version etc but nothing fixed it.

Then recently, I have stumbled upon topics from other LimeSDR users pin-pointing issues with their devices to the soldering of their USB controller. Said topics mention that by heating up USB controller chip, LimeSDR would start working again until the inevitable cooldown.

So having nothing to lose I tried it, and bingo:

Before heating up:

After heating up a few minutes:

When heated up all other applications work perfectly, I tested with GNURadio and GQRX

Does my reasoning and the evidence I have collected seem conclusive to you too as to the fate of my board ? I am assuming this is a problem common-ish amongst early batches of the LimeSDR-USB.

Thanks and best regards,
Théo.

EDIT; edited information about loopback test
EDIT 2; added link to other topic on described issue

Error: Read(64 bytes) failed Write(64 bytes) failed
#2

@tbueno - Theo,

I have read posts in the past about issues with the LMS-7002 having cracked solder balls to the circuit board creating issues similar or very much like your board symptoms. About the only way it was possible to recover was to reflow the board again by hand (if you have the equipment - this would include a hot-air soldering/desoldering tool) and patience. I have also read other users just taking their board and baking it in an oven for 3 - 5 minutes and then letting it air cool. It appears that when the board is cold there’s a fractured solder joint on your LMS-7002 that creates the issues you’re seeing, and then when the LMS-7002 heats up the fractures close because of the thermal expansion of the fracture against the board closing that gap.

Before you do anything, please do a search on this forum on the keywords: ‘intermittent’, ‘fracture’ and ‘BGA’ and see if you can review those threads for any information on how those users with board problems (one of the users was ‘BrandonTheBig’ if I recall right, but there have been other users that had their LMS7002 come off the board when the board was dropped and they managed to get it back on the board and put the board in an oven to reflow the connections and got it working.

Hope this helps and welcome to the forum…!

73 de Marty, KN0CK

#3

Hi Marty,

Thanks for your input.

I am thinking this is more related to the USB chip as when cold, board / FPGA can’t be flashed and won’t return any command correctly.

I am willing to try the solutions you mentioned, but only as last resort if the guys from CrowdSupply/Lime can’t offer any solution to me.

The forum thread I have mentioned in my first post is that one: LimeSDR-USB gateware version is not recognizeable (temperature related)

Théo.

1 Like