LimeSDR-GRC snap - gnuradio-companion cannot start


#1

I just installed the various snaps from the LimeNET store.
When trying to start the gnuradio-companion, I get the error:

/snap/limesdr-grc/3/bin/desktop-launch: /snap/limesdr-grc/3/bin/gnuradio-companion: /home/jblum/src/snapcraft-sandbox/limesdr-grc/stage/usr/bin/python2: bad interpreter: No such file or directory.

Has anybody been able to run this application?

regards
Rainer


#2

Oh dear. It looks like gnuradio captured the path to my specific python interpreter (I think, since obviously it has my username in the path). It didnt previously do this. I think there was a change to the cmakelists to hardcode python into gnuradio companion executable shebang line. I will have to look into this. It might be something to again patch with the appropriate snap env var.


#3

I’ve just installed LimeSDR+GRC from Ubuntu One repo and I find the same issue with my installation. Are you aware of any solution to this problem?


#4

I didnt upload a new snap, but I think I fixed it here: https://github.com/myriadrf/snapcraft-sandbox/commit/3feff189e083710f2049c5134202c344e489064d

We need the default python shebang, but gnuradio overwrites this. So we have to fix it up again with sed.

Anyone interested, please build the snap and give it a try


#5

just installed a fresh copy and still getting the same error as OP. Is there a way to update the PATH? where is this (home/jblum/src/snapcraft-sandbox/limesdr-grc/stage/usr/bin/python2) reference coming from?


#6

@voxmeus,

That probably is Josh Blum’s personal path on his machine - it’ll have to match or you’ll have to change the PATH statement to your own PATH setting.

73 de Marty, KN0CK


#7

so, i actually flashed the disk, reinstalled with username jblum, but it looks like the path is installed to a /snapcraft-sandbox/ location. mine gets installed to /snap/limesdr-grc/. What kind of package installs to /snapcraft-sandbox/ ?


#8

@voxmeus - David,

That’s a tool that’s used for creating ‘Snaps’ that are used in Linux as universal packages - Snapcraft is the app they use for that. The ‘Sandbox’ reference is what’s used on Github.

73 de Marty, KN0CK


#9

If you read my previous post: LimeSDR-GRC snap - gnuradio-companion cannot start - gnuradio was hardcoding paths into the python files, I worked around it, but you have to rebuild the snap.

The snaps are there as examples, feel free to update them or rebuild them as needed. If you would like to upload new snaps, ask @andrewback about access.