Limesdr ERROR:TransferPacket;Write failed(ret=-1)

win10 、limesdr mini 、Lime Suite GUI(2020-10-29)
Prompt from time to time:
ERROR:TransferPacket;Write failed(ret=-1)
The connection is then disconnected,
There is no fault in the Ubuntu system,
How to solve this problem?

Hey, I had this problem a couple days ago. I think it was a mix of high temperature and an extension cable I was using in order to not have the board attached direct to my USB port. It was like hell trying to figure it out. I looked into the FIFO usb configuration chip (there are other posts here explaining how to do it) cus I thought it was for sure a communication problem (otherwise I would assume my board was broken but it was working just fine before). Then after that I was trying to update the firmware and it was not being able to do it up to end. Then I tried to force the flashing of the firmware and the same happened. The Quick Test would report errors as well. I read somewhere that someone had problem using an USB extension cable and I tried then to remove it. Since then it’s working just fine.