LimeSDR + Easyfix1 = dead lime


I regrettably kickstarted the limesdr and found when I received it that it wasn’t good for much more than receiving local FM stations. I tossed it into a drawer where it lived until last week when I decided to try to make it do something else. I did some reading and found that my desire for receiving HF might require performing the Easyfix1. The soldering aspect didn’t scare me as I’ve done a fair amount of soldering. I removed the required inductor and plugged the Lime back in. However now my LimeSDR is completely dead. It came up in Lime Suite once but reported firmware version 0. I tried reflashing it and now it does not respond to USB at all.

Let this be a warning to anyone thinking about performing this “fix”. This board is extremely delicate. Unfortunately without performing this modification it seems it isn’t much good for HF anyway.

Try another cord. I have abused the heck out of my Limes. 1 was just the board in my center console for 4 months.
If you get the HW0 & FW0, you may want to reflash the Cypress chip.
If you are in the USA, I may try to resurect it for you.


Try another cord.

Perhaps. I will try another. I have also tried plugging it directly into the usb port on the computer, so I’m skeptical this will change anything.

If you get the HW0 & FW0, you may want to reflash the Cypress chip.

I don’t think I know what any of this means.

Go to the Cypress USB website. THey have a software package to reflash it all…


Hi @beatmania,

What OS do you use? What LED activity do you see on the board? What USB (3 or 2) are you using?

These are not related unless you ruin your board completely.
Try LimeQuickTest and post log file here.

I had similar issue. It is the LimeSDR USB connector itself most likely. Mine became erratic. Worked sometimes dead others. If you flex the USB connector it can break the tiny connections inside the USB connector.

I’ve plugged it in maybe 20 times so far. If it’s broken already then that’s just unacceptable.

I’ve tried plugging it into a wall wart and it will sometimes read the temperature in LimeSuite, and I was able to flash the FW, but that’s about it. For some reason the entirety of Pothos on Windows just crashes instantly when attempting to load the Soapy module so it probably doesn’t matter if the board works anyway.

@Zack That test is just a spam of Read(64 bytes) failed.