LimeSDR configuration speed optimisation


I was just reading about the LimeSDR configuration speed optimisation and was wondering whether it requires updating the firmware or the FPGA image on the board?


I have updated the firmware and FPGA image to the latest HW_1.2 mentioned in the wiki and it does indeed feels faster compared to what I remember. Very nice! :slight_smile:

Good point! Updated the post to add a note on this.

Followed the same procedure, and updated both the FX3 and FPGA images normally. Can’t find the board any longer in a Win 10 system. Have tried reloading the Cypress driver without success. Recovery procedure?

Also can’t connect to it in Ubuntu, but it is seen when plugged into USB:

[ 72.625135] usb 4-1: new SuperSpeed USB device number 2 using xhci_hcd
[ 72.642002] usb 4-1: LPM exit latency is zeroed, disabling LPM.
[ 72.643064] usb 4-1: New USB device found, idVendor=1d50, idProduct=6108
[ 72.643069] usb 4-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 72.643072] usb 4-1: Product: LimeSDR-USB
[ 72.643074] usb 4-1: Manufacturer: Myriad-RF
[ 72.643077] usb 4-1: SerialNumber: 0009052300C51E32

Have you tried to re-flash with an earlier version ? Say v1.3 instead of v1.4. In programing mode I suspect that it will still flash fine even if the OS can not see the device as functioning correctly.

Also maybe check that the file you downloaded was not corrupt, I get the following checksums for the files I have:
$ md5sum v*/*
ba44d89fe880a141c0692a4dfc1805d8 v1.1/LimeSDR-USB_fx3_fw.img
b780860d72a6e330b8586144ba303312 v1.1/LimeSDR-USB_lms7_trx.rbf
d29fe7ff5badc893388248c626754df3 v1.2/LimeSDR-USB_fx3_fw.img
b780860d72a6e330b8586144ba303312 v1.2/LimeSDR-USB_lms7_trx.rbf
9aa68db09d664db2e76a979d913eeca3 v1.3/LimeSDR-USB_fx3_fw.img
b780860d72a6e330b8586144ba303312 v1.3/LimeSDR-USB_lms7_trx.rbf
9aa68db09d664db2e76a979d913eeca3 v1.4/LimeSDR-USB_fx3_fw.img
ca89b6094ceeaa9d47a0532fe406137d v1.4/LimeSDR-USB_lms7_trx.rbf
$ sha1sum v*/*
69d4385c113efd2365d9983d2f4601ced36d2a24 v1.1/LimeSDR-USB_fx3_fw.img
ddc7218917e02cc79157c33eea617db4e9c12e55 v1.1/LimeSDR-USB_lms7_trx.rbf
9dea2a702d41d93f88be1b8dca6791672c91bd86 v1.2/LimeSDR-USB_fx3_fw.img
ddc7218917e02cc79157c33eea617db4e9c12e55 v1.2/LimeSDR-USB_lms7_trx.rbf
f83f9a927804eb0a8343dc1f875f5a2dc6f650f9 v1.3/LimeSDR-USB_fx3_fw.img
ddc7218917e02cc79157c33eea617db4e9c12e55 v1.3/LimeSDR-USB_lms7_trx.rbf
f83f9a927804eb0a8343dc1f875f5a2dc6f650f9 v1.4/LimeSDR-USB_fx3_fw.img
ac97b23820b574cad841d577c4fdcb434e7bca74 v1.4/LimeSDR-USB_lms7_trx.rbf

I’ve tried all of the FX3 firmware versions. The only one that the Win 10 computer will work with is on the USB drive that it came with which is marked as 1.2.

It won’t stream data with any the usual SDR software but with the 1.2 version of the FX3 firmware, LimeSuite can connect to it and perform some commands.

The board has a revision marking of 1.2s

I also have a v1.2 board. I can’t help you windows or the Limesuite GUI. I used the LimeUtil command line tool that is included in the limesuite source tree, then SoapySDRUtil to test connection to the device.

You could try to reflash your board in linux using LimeUtil.

@n4mho the Cypress Windows driver doesn’t work with this update and a Windows driver for use with the new SPI architecture is in the process of being published to GitHub. In the meantime if you wanted to revert to using previous versions of the firmware and gateware, you could load the former first by removing the FX3 boot jumper and then using the Cypress provided utility to program this.

@andrewback Right, I’ve removed J13 a few times already to get back to the bootloader. I’m just trying to get to a working configuration. I have the LimeSuite set of tools and applications installed in Windows 10 and also in Ubuntu 16.04 via the snap packages. I added the udev rules.

What I see is that in LimeSuite, the FFT viewer takes a very long time to produce the graph, and it doesn’t update. In gqrx, the spectrum and waterfall never appear, but the S-meter indication goes full scale and stays there. I’ve tried loading all the available drivers, including the ones on the supplied USB drive.

I recall on my bladeRF, they also stated that the Cypress driver did not work for some functions, and suggested another driver for use.

The board that I’m using is the first contest giveway that was sent to Steve. We live a few miles apart and I borrowed it for evaluation.


The latest update in FX3 firmware incorporates VID/PID change. This is why Cypress drivers are not suitable any more. Here is a link to new drivers.
Note please, that drivers are not digitally signed yet.

Thanks, that does take care of the Windows driver problem. Still left with the original problem of not being able to stream data in gqrx and the FFT Viewer in LimeSuite appears to collect one set of data, displays the waveform and then stops. The RX and TX data rates go to about 4-5 GB/s for a moment and then return to 0.

Tried the original supplied firmware and those in the #Flashing_Images section with similar results.

@n4mho Are you using the latest LimeSuite?

I’ve tried the version that came on the USB drive which asks for the separate control and data stream connections as well as the latest one from the snap package.

Pothos from the snap package complains of firmware versions unless I use the files from the USB drive. I will include its log when I have time. It appears to be communicating with the LMS7002, but complains of a VCO frequency set too low. It does the same if I load the firmware version for HW 1.2 from git.

Sorry, to clarify I have the snaps installed in Ubuntu 16.04 LTS, but the Pothos install that I was using in Windows 10.