LimeSDR arrived but can't get it to work

Just the power led is green.

Could you post the board photo (top and bottom), please.

Here are the pictures.

Here are my diagnostics:

11:26:13.677: Radio LimeSDR> Connecting, address = USB 3.0 (LimeSDR-USB), media=USB, module=STREAM, serial=0009060B00461216, index=0
11:26:13.678: Radio LimeSDR> OK
11:26:13.678: Radio LimeSDR> Initialising
11:26:13.678: Radio LimeSDR> OK
11:26:13.678: Radio LimeSDR> Device: device name ............: LimeSDR-USB
11:26:13.678: Radio LimeSDR>         expansion name .........: UNSUPPORTED
11:26:13.678: Radio LimeSDR>         firmware version .......: 2
11:26:13.678: Radio LimeSDR>         hardware version .......: 4
11:26:13.678: Radio LimeSDR>         protocol version .......: 1
11:26:13.678: Radio LimeSDR>         board serial number ....: x00461216
11:26:13.678: Radio LimeSDR>         gateware version .......: 2
11:26:13.679: Radio LimeSDR>         gateware revision ......: 5
11:26:13.679: Radio LimeSDR>         gateware target board ..: LimeSDR-USB

Hi @SimonG4ELI,

Yes, that’s the case. You need to update Firmware to fix automatic detection of the board after boot issue.

OK, no problem.

When i understand it correctly the gateware firmware is for the fpga. And i can program the on-board flash with this firmware but it seems the fpga is never loaded with this firmware. When i try to load the gateware firmware directly to the fpga with LimeSuiteGUI->programming i only get an error message.

So is there maybe a way to test if the fpga on my board works at all?

[quote=“Fox_Mulder, post:27, topic:744, full:true”]
When i understand it correctly the gateware firmware is for the fpga. [/quote]

Do you have by chance Altera USB Blaster?

Sorry, i don’t have this. I can only offer an oscilloscope, logic analyzer and multimeter but not such specialized equipment.

But today i was lucky to get my hands at another LimeSDR, even only for a very short time. At the university another student also had it with him when i saw him today. I lend it and attached to my laptop and it looked way better than mine. The gateware version was shown correct and a few simple tests went through without any errors.
This lets me think that possibly something on the hardware side is defective on my board.


Addition: I forgot that i have an Atmel AVR JTAG Ice3 Debugger if this helps.

Hi @Fox_Mulder,
Could you please contact Crowd Supply to replace your board.

1 Like

Ok. This is a sad day for me when i think about the long time i have to wait for a replacement from Germany to USA and back. :sob:

But thanks for the help so far.

See if your fellow student/friend can re-initialize the Lime on their computer … probably not going to work, but it is a lot faster than the post.

Not the computer is the problem. I tried two computers with Win7, Debian8 and Ubuntu 16.04 and mine worked at none of these configurations while his worked out of the box at one of these computers. So i don’t think it is possible to reinitialize it at another computer. :confused:

At the beginning and mid of last week i wrote two emails to Crowd Supply and asked them what the correct way is to replace my defective LimeSDR. But until now i got no response at all from them. And they write on their contact page that they will try to answer all emails within 24 hours. :angry:

So does anybody here know what the best procedure is to get the board replaced?
Should i just send it there with a little writing or should i first wait for an ok from them or maybe some case number?

And is there anything i could do to not pay taxes again in Germany because it is a replacement?


Hi Rainer,

Just sent e-mail to Crowd Supply and copied you in. Hoping to get this resolved soon.


I sent my LimeSDR back at 25. February and the tracking stopped at 6. March. Since than USPS only shows that the package is out for delivery. Does this mean the package has still not arrived?

I tried to sent USPS an email about the status but this only works with some web form and a valid address in the USA which i don’t have. Quite strange behavior for customer support.

@andrewback can you maybe tell me if it arrived or not?

Here is the link to the USPS tracking site for the package:


Hi Rainer, I’m afraid I can’t confirm receipt, as I’m based in the UK and Crowd Supply are in the US. With such things the best way to follow-up is via e-mail with Crowd Supply. I’ll ping CS now via the previous e-mail chain.

Ok. I hope i get this solved with help of the Crowd Supply people.

My replaced LimeSDR arrived today and it is working as expected. Thanks for the help so far. :slight_smile:



Hi Rainer,

That is a relief to hear! Thanks for letting us know and look forward to seeing what you do with your LimeSDR :slight_smile: