Lime SDR Mini - Odd Two Peak Pattern on Many Frequencies


#1

I’m getting a twin-peak pattern on many bands that I’ve tested on the Lime SDR Mini. I’ve tried different bandwidths and with enough fiddling with the frequency setting (clicking on the waterfall) it will sometimes go away and be normal again. I’m using SDR Console and have noted this on that board. Maybe it is a bad setting somewhere.

The Lime SDR Mini is deaf when I get the twin peaks and they even appear with no antenna connected.

I need to try another SDR program if I can get another one working.

Any thoughts in the interim would be welcome. Simon advised he would look at it some time this week as well.

I can post a picture when I have rights to do so.

Thank you,

Mike
K6MSM


#2

I was going to say that I’m not sure what the current status is with SDR Console, in that if device gateware is updated it may need updating also — or at least linking against a new version of Lime Suite. But sounds like you’re in touch with Simon, which is good.

You might like to also give SDRangel a try. @martywittrock is a big fan and there are quite a few of his posts on here where he’s assisted others in getting up and running.


#3

I had that same problem, it was my noisy video card doing me in. Switched computers and it went away.


#4

Thanks. Let me see if I can update a couple pics. If this works, did it look like the first one?

If I move the frequency a little, sometimes it goes away (see 2nd pic)

Mike
K6MSM


#5

Ahh! I see whats up.
I also get that one but it is a mixing product from an outside unidentified source.
If you use a band pass filter does it go away?
On my setup that same noise was laying waste to the noise floor on the Marine and aviation bands, would come and go and occasionally move around.
Adding marine and air band filters made it disappear in those bands, you of course would want to use filters for whatever band you are listening to or watching to get the same relief.


#6

I tested it in the mobile and on the mobile laptop (different computer) and had the same result.

A filter hasn’t helped as it still occurs with no antenna connected as well. I’m going to test another desktop again.

If I could get Gqrx (I think it is) working, I could test another program. It doesn’t give me a waterfall on Windows. I’m going to try setting up a virtual Linux machine as well. I haven’t figured out SDRAngel yet, but read it doesn’t work with Windows with the Lime Mini. Maybe the same problem plagues Gqrx.

73,

Mike
K6MSM


#7

I still can’t get Gqrx to work with the Lime Mini. It works fine with the SDR Play 2. Is the Lime Mini not supported? I’ve fiddled with many settings to no avail.

This is under W10.

Mike
K6MSM


#8

Contact crowd supply and get a replacement then, you have run all the reasonable tests available and it still persists as a huge loss of noise floor.


#9

Ok, thanks. I put in a request for a return or exchange.


#10

And they finally responded just told me to post here. sigh

I am working with Simon at SDR Console on a software fix for this problem, so I will complete that first before deciding what to do next.


#11

I’m at a dead end on this issue with SDR Console. How do I get a replacement? Crowd Supply said I needed to request a replacement here.

Thank you,

Mike
K6MSM


#12

Following up. How do I request a replacement? As noted above, Crowd Supply advised I need to get approval from here.

Thank you,

Mike
K6MSM


#13

@Zack, could you help diagnose, please, and just confirm that we do in fact need to arrange an RMA.


#14

Hi @K6MSM,

Run QuickTest software and paste log file here, please.


#15

[ TESTING STARTED ]
->Start time: Thu Sep 27 06:39:08 2018

->Device: LimeSDR Mini, media=USB 3, module=FT601, serial=1D40F9BD8DD807, index=0
Serial Number: 1D40F9BD8DD807

[ Clock Network Test ]
->REF clock test
Test results: 11262; 24459; 37656 - PASSED
->VCTCXO test
Results : 6711109 (min); 6711270 (max) - PASSED
->Clock Network Test PASSED

[ FPGA EEPROM Test ]
->Read EEPROM
->Read data: 12 06 1D 12 06 1D 02
->FPGA EEPROM Test PASSED

[ LMS7002M Test ]
->Perform Registers Test
->External Reset line test
Reg 0x20: Write value 0xFFFD, Read value 0xFFFD
Reg 0x20: value after reset 0x0FFFF
->LMS7002M Test PASSED

[ RF Loopback Test ]
->Configure LMS
->Run Tests (TX_2 -> LNA_W):
CH0 (SXR=1000.0MHz, SXT=1005.0MHz): Result:(-12.9 dBFS, 5.00 MHz) - PASSED
->Run Tests (TX_1 -> LNA_H):
CH0 (SXR=2100.0MHz, SXT=2105.0MHz): Result:(-13.1 dBFS, 5.00 MHz) - PASSED
->RF Loopback Test PASSED

=> Board tests PASSED <=

Elapsed time: 4.62 seconds


#16

Hi @K6MSM,

I see no issues with the board.


#17

Then I’m back to my original question of why does it have the problem when I change frequencies. Something is wrong. Did you see the above screen cap with the twin peaks?

Thanks,

Mike
K6MSM