Lime Mini 2 - Botched FPGA upload

Salutations and greetings from Sunny Bangkok,

This is my first posting.
I need help as I think I have caused the FPGA to be erased somehow.

I received my brand new Lime SDR Mini2 today from Crowd supply after a patient wait of almost 9 mths.
I then had a brief look at the setup instructions on the website and then plugged it into y Mac USB3 External port (its on an extension hub).

On plug in, the LED’s seemed to blink then stay static.
I ran SDR Angel, and it kept crashing on startup.

I then Tried SDR++ and it would see the device but nothing happened on starting the stream.
After reading a little of the WIKI, I then loaded the LIME SUITE. It loaded ok from the command line.

I tried “LimeUtil --update” to ensure it was up-to-date (it would report “Programming update failed”)
I promptly read further and saw a topic about updating USB3_FX3

I downloaded the RAW image file LimeSDR-USB_fx3_fw.img, used the LimeSuiteGUI, to connect to my device, (successfully) then the menu MODULES>Programming>
I selected FPGA FLASH, then uploaded the LimeSDR-USB_fx3_fw.img successfully.

The LEDS’ were blinking, so I thought all was well. I exited the LimeSuiteGUI.

I tried SDR Angel and SDR++ again with no joy.

I unplugged the Mini 2, and plugged it in again. This time NO LEDS lit up!

LimeSuiteGUI OPTIONS>Connection Settings> sees LimeSDR Mini [USB3.0] 1DAxxxxxxxxx but reports

Error: Transferpacket: Write failed (ret=0)
INFO: Connected Control port: Unknown FW:0 HW:0 Protocol:0 GW:0.0 Ref Clk: -0.00Mhz

I would be very grateful for your kind assistance to guide me in recovering the LIME SDR Mini2.
then perhaps a pointer for newbies like me to get it going with common SDR software like SDR++ and ADRangel

Many thanks in advance for your patience and assistance.

LimeSDR USB is a totally different board:

There is a complete list here:

LimeSDR Mini v2 does not have an FX3 controller and uses a different FPGA, from a different vendor. Sounds like you may have possibly bricked it.

Can you run the following and post the output:



follow instructions from FAQ to recover your LimeSDR-Mini v2:
I cannot connect board to LimeSuite GUI, no LEDs are blinking how can I recover my board?

Dear Andrew,
Thank you for the quick response.

This is the result.

cs@MacBook-Pro-15-Grey ~ % LimeQuickTest


->Start time: Mon Dec 18 17:37:43 2023

->LimeSuite version: 22.09.1-release

libusb: warning [darwin_transfer_status] transfer error: timed out

TransferPacket: Read failed (ret=0)

libusb: warning [darwin_transfer_status] transfer error: timed out

TransferPacket: Read failed (ret=0)

libusb: warning [darwin_transfer_status] transfer error: timed out

TransferPacket: Read failed (ret=0)

libusb: warning [darwin_transfer_status] transfer error: timed out

TransferPacket: Write failed (ret=0)

libusb: warning [darwin_transfer_status] transfer error: timed out

TransferPacket: Write failed (ret=0)

libusb: warning [darwin_transfer_status] transfer error: timed out

TransferPacket: Write failed (ret=0)

Board not supported

Failed to connect

libusb: warning [libusb_exit] device 3.15 still referenced

libusb: warning [libusb_exit] device 3.4 still referenced

libusb: warning [libusb_exit] device 3.1 still referenced

libusb: warning [libusb_exit] application left some devices open

cs@MacBook-Pro-15-Grey ~ %


I fear it has been bricked.

Please advise how I might un-brick it.

See above details posted by @VytautasB. You will likely need to use JTAG and buy an adapter.


Thank you for the suggestion.
For some reason, I cannot seem to open your link.

Thank you again for your pointers. I finally got to the webpage, perhaps some maintenance was being done and it was not reachable.

I will find a JTAG programmer, Read the notes fully and revert.

Thank you all.

I checked when you posted, worked fine for me and we weren’t doing any maintenance, so I’m not sure what the problem was. In any case, glad you have the info now.

Greetings again, learned advisors.

The FTDI based J-Tag programmer arrived today in the morning mail.
I have done the hook up to the LIME board. The LIME board and FTDI device are both plugged into a USB3 Hub on my PC.

I run the Lattice Diamond Programmer which recognises my FTDI device (photo enclosed)

Which is identical to your example on the J-Tag programming page.

Unfortunately when a scan is done, it does not see or identify the FPGA. (photo below)

I then checked to ensure my settings for the FTDI device were correct and used the FTDI utility to check. All seemed correct. (photo)

When I attempt a manual setting of the device family to ECP5U and then device to LFE5U-45F I again get programming failed because it could not recognise the ID of the chip.

Again I would be very grateful for any advice as to what to do next.
Thank you in advance,
warm regards

Tagging @zack and @VytautasB, as they would be best positioned to advise.

This would indicate problems with JTAG cable connection because you should be able at least see Lattice FPGA device during JTAG scan.

What JTAG programmer are you using?

  1. Double check if JTAG is properly connected as described in:
  2. Try connecting LimeSDR-Mini v2 board directly to USB3.0 port on your pc

Thank you very much for the pointers.

Your suggestion 2, solved the problem!.
When I connected the LIME SDR-Mini v2 board directly to a USB 3 port, it was immediately recognised by the FTDI JTAG programmer when a scan was done.

The I managed to upload all the files in order and now have a working device.
Thank you so much for your kind assistance.

1 Like