Issues with LimeSDR setup on Ubuntu 16.04

#1

Hello everyone,

I am very new to LimeSDR and radio communication in general. I have been trying to setup the LimeSDR USB on an Ubuntu 16.04 PC but I have the following issues. I have come to the conclusion that it might be a USB driver issue, but I am not sure if this is correct or how to solve it.

  1. On using the ‘lsusb’ command, the LimeSDR is shown as ‘OpenMoko, Inc’. I’m not sure if this is how it should look like, but I’ve seen this issue seen elsewhere but with no solution
  2. I tried connecting with the device using the LimeSuite GUI. I went to Options > Connection Settings to connect, but every time I click on Connection Settings, the GUI crashes.
  3. On using the command LimeUtils –info , I cannot see the supported connections. It shows a symbol lookup error as seen in the picture below.

download

UPDATE :

I had installed LimeSuite using the package installer, but decided to uninstall and build from source. I´m getting the following error while trying to make:

The error definitely has something to do with libusb in the ConnectionFX3 and ConnectionFTDI files, both CMakeLists use libusb-1.0 and I’ve got libusb-1.0 correctly installed. In the connectionFX3 and connectionFTDI header files, I included the full path to libusb.h. Now, I get this:

Please help! Any direction would be very helpful!

Thanks!

Aditya

#2

Try installing libusb:
sudo apt-get install libusb-1.0-0-dev
sudo ldconfig

#3

I tried that, didn’t work. I’m still getting the same error

#4

Did you build from source? If so you may need to rebuild after installing libusb-dev.

#5

@andrewback @ricardas I uninstalled everything and started from scratch, but decided to build from source this time. Still getting errors.

I’ve updated the question, maybe this additional information might help.

#6

did you delete the LimeSuite/build folder after you installed libusb-1.0-0-dev?

#7

Yes, did that. The results in the updated part of my question are after that step.