How to make grgsm_scanner work?

#1

Hello. I got my LimeSDR two days ago and were able to configure it to work with GNU Radio.
livemon.grc is working for me and I can also sniff IMSI numbers. But I have problems with “grgsm_scanner” it halfly work.
Command I tried:

sudo python -u ./grgsm_scanner -s SAMPLES --args=driver=lime,soapy=0

I tried different bands and samples - 10M, 20M, 24M, 30M.

It’s give me some information with 10M, but it’s less then a half of information, thats my bladerf gives me, How can I fix this?

Also it works quit unstable(all leds become green and the programm doesn’t output anything)and continue to light even after the program stop working.

#2

any help?

#3

Perhaps contact the developer(s)? That’s where I’d start if other things work but one app does not and I were stuck for ideas.

#4

It’s show me half of the normal output. I think that the problem is in my lime, because low adc always show 0 MHz

#5

hey, where u able to fix that ?

#6

sorry. If it’s still actual: there are 2 ways for now:

  1. Use old code from git (two commits before last)
  2. Use latest sources from osmocom
#7

There is now a fork that uses the gr-limesdr source/sink blocks instead of gr-osomosdr.

We’re looking into getting this support upstream. Also, there may still be some tweaks required, so would be interested to hear how you get on.

#8

grgsm_scanner doesn’t work for me at all. grgsm_livemon have no changes. I added lime sink by myself (I set freq and add serial number) it seems that grgsm_livemon also doesn’ work correctly for me. I made a quick test on limesdr-mini. Maybe I didn’t make some setup in lime sink (normaly I use osmosdr).

#9

Thanks for trying this out. grgsm_livemon has not been updated.

@IgnasJ any suggestions regarding grgsm_scanner?

#10

Any updates? grgsm_scanner output stuck after “stream setup done.”

Device number 0 from the list is used.
Reference clock 30.72 MHz
##################

INFO: device_handler::enable_channels(): SISO CH0 set for device number 0.
INFO: device_handler::set_samp_rate(): set sampling rate: 2 MS/s.
INFO: device_handler::set_rf_freq(): RF frequency set [RX]: 925.9 MHz.
RX LPF configured
INFO: device_handler::set_analog_filter(): INFO: device_handler::set_gain(): set gain [RX] CH0: 24 dB.
Using Volk machine: avx2_64_mmx_orc
INFO: source_impl::init_stream(): source channel 0 (device nr. 0) stream setup done.

#11

The version in the fork on GitLab should work provided you have gr-limesdr installed.