Help Please Osmocom Kali Linux Problem?

#1

Why I Am Taking This Error You Know ?

root@murat:/etc# cd osmocom
root@murat:/etc/osmocom# ls
osmo-ggsn.cfg osmo-hnbgw.cfg osmo-msc.cfg osmo-stp.cfg osmo-trx-uhd.cfg
osmo-hlr.cfg osmo-mgw.cfg osmo-pcu.cfg osmo-trx.cfg
root@murat:/etc/osmocom# osmo-trx-uhd
Info: SSE3 support compiled in and supported by CPU
Info: SSE4.1 support compiled in and supported by CPU
Config Settings
Log Level… 7
Device args… name=gsm900,fpga=/usr/share/uhd/images/b200_gsm900.bin
TRX Base Port… 5700
TRX Address… 127.0.0.2
GSM BTS Address… 127.0.0.2
Channels… 1
Tx Samples-per-Symbol… 4
Rx Samples-per-Symbol… 4
EDGE support… 0
Reference… 1
C0 Filler Table… 1
Multi-Carrier… 0
Tuning offset… 0
RSSI to dBm offset… 0
Swap channels… 0
Tx Antennas… ‘’
Rx Antennas… ‘’

[INFO] [UHD] linux; GNU C++ version 8.2.0; Boost_106700; UHD_3.13.1.0-3
DMAIN <0000> UHDDevice.cpp:591 [tid=140600981016128] Unsupported device Audio
DMAIN <0000> osmo-trx.cpp:446 [tid=140600981016128] Failed to create radio device
Shutting down transceiver…

#2

I Have Big Problem Please Help To Me ? My Computer Defined 2 UHD Device ? But I Have Only One UHD Device Limesdr ? How I Can Correct This ?

root@murat:/etc/osmocom# uhd_find_devices
[INFO] [UHD] linux; GNU C++ version 8.2.0; Boost_106700; UHD_3.13.1.0-3

– UHD Device 0

Device Address:
serial:
default_input: False
default_input: True
default_output: False
default_output: True
device_id: 0
device_id: 2
driver: audio
label: default
label: hw:HDA Intel PCH,0
type: soapy


– UHD Device 1

Device Address:
serial: 1D4C3893CE8AAC
addr: 24607:1027
driver: lime
label: LimeSDR Mini [USB 2.0] 1D4C3893CE8AAC
media: USB 2.0
module: FT601
name: LimeSDR Mini
type: soapy

#3

I removed All Of Sound Card Software İn Kali Linux And I Arrived This But My Phone Can’t See Any 2G Cell ? Why ? I want to connect my phone this I am excited A lot But My Phone Don’t See any 2G Cell around ?

root@murat:/etc# osmo-trx-uhd -C ~/Downloads/osmo-trx-limesdr.cfg
Info: SSE3 support compiled in and supported by CPU
Info: SSE4.1 support compiled in and supported by CPU
Wed May 15 07:01:29 2019 DLGLOBAL <0001> telnet_interface.c:104 telnet at 127.0.0.1 4237
Wed May 15 07:01:29 2019 DLCTRL <0008> control_if.c:887 CTRL at 127.0.0.1 4236
Config Settings
Log Level… 0
Device args…
TRX Base Port… 5700
TRX Address… 127.0.0.1
GSM BTS Address… 127.0.0.1
Channels… 1
Tx Samples-per-Symbol… 4
Rx Samples-per-Symbol… 4
EDGE support… 0
Reference… 0
C0 Filler Table… 1
Multi-Carrier… 0
Tuning offset… 0
RSSI to dBm offset… 0
Swap channels… 0
Tx Antennas… ‘BAND1’
Rx Antennas… ‘LNAW’

[INFO] [UHD] linux; GNU C++ version 8.2.0; Boost_106700; UHD_3.13.1.0-3
[INFO] [UHDSoapyDevice] Make connection: ‘LimeSDR Mini [USB 2.0] 1D4C3893CE8AAC’
[INFO] [UHDSoapyDevice] Reference clock 40.00 MHz
[INFO] [UHDSoapyDevice] Device name: LimeSDR-Mini
[INFO] [UHDSoapyDevice] Reference: 40 MHz
[INFO] [UHDSoapyDevice] LMS7002M calibration values caching Disable
[INFO] [UHDSoapyDevice] Filter calibrated. Filter order-4th, filter bandwidth set to 5 MHz.Real pole 1st order filter set to 2.5 MHz. Preemphasis filter not active
[INFO] [UHDSoapyDevice] TX LPF configured
[INFO] [UHDSoapyDevice] RX LPF configured
– Transceiver active with 1 channel(s)

#5

You should be using osmo-trx-lms and not osno-trx-uhd. Please see the Osmocom wiki:

https://osmocom.org/projects/osmotrx/wiki/LimeSDR_Family

1 Like
#6

İn Kali Linux I installed osmocom with apt-get install osmo-trx osmo-bts vs vs
When I write osmo-trx-lms İt not start. How I can use with lms this ?
I am writting console it is saying to me no have prompt

root@murat:~# osmo-trx-lms
bash: osmo-trx-lms: komut yok
root@murat:~# osmo-trx-lms
bash: osmo-trx-lms: komut yok
root@murat:~#

#7

I swear it’s enough. I haven’t seen a stupid system in my life like linux. I want to run this application in windows. Is it possible I could do that? I tried 5000 times. I’ve never been able to install an application on this jerks linux system.

https://osmocom.org/projects/osmotrx/wiki/LimeSDR_Build_From_Source

I can not make -j5 it giving to me a stupid error

Making all in Transceiver52M
make[3]: Entering directory ‘/root/osmo-trx/tests/Transceiver52M’
cd …/… && /bin/bash ./config.status tests/Transceiver52M/Makefile depfiles
config.status: creating tests/Transceiver52M/Makefile
config.status: executing depfiles commands
make[3]: Nothing to be done for ‘all’.
make[3]: Leaving directory ‘/root/osmo-trx/tests/Transceiver52M’
make[3]: Entering directory ‘/root/osmo-trx/tests’
make[3]: Nothing to be done for ‘all-am’.
make[3]: Leaving directory ‘/root/osmo-trx/tests’
make[2]: Leaving directory ‘/root/osmo-trx/tests’
make[2]: Entering directory ‘/root/osmo-trx’
make[2]: Leaving directory ‘/root/osmo-trx’
make[1]: Leaving directory ‘/root/osmo-trx’

#8

Yes I succeeded in 5001 test. But I Cant see my bts in my phone again ?
I Turned my connection 2G in my phone . I install osmo-trx-lms and I configured osmo-bts.cfg but I cant see my bts in my phone . Why ?

root@murat:~# osmo-trx-lms -C ~/Downloads/osmo-trx-limesdrr.cfg
Info: SSE3 support compiled in and supported by CPU
Info: SSE4.1 support compiled in and supported by CPU
Sat May 18 02:05:37 2019 DLGLOBAL <0004> telnet_interface.c:104 telnet at 127.0.0.1 4237
Sat May 18 02:05:37 2019 DLCTRL <000b> control_if.c:887 CTRL at 127.0.0.1 4236
Sat May 18 02:05:37 2019 DDEV <0002> LMSDevice.cpp:51 [tid=140359777198464] creating LMS device…
Sat May 18 02:05:37 2019 DDEV <0002> LMSDevice.cpp:143 [tid=140359777198464] Opening LMS device…
Sat May 18 02:05:37 2019 DDEV <0002> LMSDevice.cpp:149 [tid=140359777198464] Devices found: 1
Sat May 18 02:05:37 2019 DDEV <0002> LMSDevice.cpp:159 [tid=140359777198464] Device [0]: LimeSDR Mini, media=USB 2.0, module=FT601, addr=24607:1027, serial=1D4C3893CE8AAC
Sat May 18 02:05:37 2019 DDEV <0002> LMSDevice.cpp:168 [tid=140359777198464] Using device[0]
Sat May 18 02:05:37 2019 DDEV <0002> LMSDevice.cpp:194 [tid=140359777198464] Init LMS device
Sat May 18 02:05:38 2019 DDEV <0002> LMSDevice.cpp:101 [tid=140359777198464] Sample Rate: Min=100000 Max=3.072e+07 Step=0
Sat May 18 02:05:38 2019 DDEV <0002> LMSDevice.cpp:230 [tid=140359777198464] Setting sample rate to 1.08333e+06 4
Sat May 18 02:05:38 2019 DDEV <0002> LMSDevice.cpp:236 [tid=140359777198464] Sample Rate: Host=1.08333e+06 RF=3.46667e+07
Sat May 18 02:05:38 2019 DMAIN <0000> osmo-trx.cpp:527 [tid=140359777198464] – Transceiver active with 1 channel(s)

#9

I Cant see my bts in my phone . My problem . MNC MCC I configured but I can not see my bts station in my phone ?

#10

İt is perfect running Thank God but I can not see my base station in phone search console . MNC MCC I configured turkey 286 AVEA 03. Why I can’t see my base station please help ?

#11

I Can not see my bts in my phone please help ? I configured osmo-bsc and osmo-msc
İt is running that
Where is problem I dont understand ? Help Please ?

root@murat:/etc/osmocom# osmo-trx-lms -C ~/Downloads/osmo-trx-limesdrr.cfg
Info: SSE3 support compiled in and supported by CPU
Info: SSE4.1 support compiled in and supported by CPU
Sat May 18 03:49:16 2019 DLGLOBAL <0004> telnet_interface.c:104 telnet at 127.0.0.1 4237
Sat May 18 03:49:16 2019 DLCTRL <000b> control_if.c:887 CTRL at 127.0.0.1 4236
Sat May 18 03:49:16 2019 DDEV <0002> LMSDevice.cpp:51 [tid=139975464436096] creating LMS device…
Sat May 18 03:49:16 2019 DDEV <0002> LMSDevice.cpp:143 [tid=139975464436096] Opening LMS device…
Sat May 18 03:49:16 2019 DDEV <0002> LMSDevice.cpp:149 [tid=139975464436096] Devices found: 1
Sat May 18 03:49:16 2019 DDEV <0002> LMSDevice.cpp:159 [tid=139975464436096] Device [0]: LimeSDR Mini, media=USB 2.0, module=FT601, addr=24607:1027, serial=1D4C3893CE8AAC
Sat May 18 03:49:16 2019 DDEV <0002> LMSDevice.cpp:168 [tid=139975464436096] Using device[0]
Sat May 18 03:49:17 2019 DDEV <0002> LMSDevice.cpp:194 [tid=139975464436096] Init LMS device
Sat May 18 03:49:17 2019 DDEV <0002> LMSDevice.cpp:101 [tid=139975464436096] Sample Rate: Min=100000 Max=3.072e+07 Step=0
Sat May 18 03:49:17 2019 DDEV <0002> LMSDevice.cpp:230 [tid=139975464436096] Setting sample rate to 1.08333e+06 4
Sat May 18 03:49:17 2019 DDEV <0002> LMSDevice.cpp:236 [tid=139975464436096] Sample Rate: Host=1.08333e+06 RF=3.46667e+07
Sat May 18 03:49:17 2019 DMAIN <0000> osmo-trx.cpp:527 [tid=139975464436096] – Transceiver active with 1 channel(s)

root@murat:/etc/osmocom# osmo-bsc
logging level cc (everything|debug|info|notice|error|fatal)
logging level mgcp (everything|debug|info|notice|error|fatal)
<0010> telnet_interface.c:104 telnet at 127.0.0.1 4242
<0012> input/ipaccess.c:846 enabling ipaccess BSC mode on 0.0.0.0 with OML 3002 and RSL 3003 TCP ports
<0017> control_if.c:887 CTRL at 127.0.0.1 4249
<0007> osmo_bsc_sigtran.c:431 Initializing SCCP connection to MSC msc-0
<0007> osmo_bsc_sigtran.c:441 CS7 Instance identifier, A-Interface: 0
<001d> sccp_user.c:370 msc-0: Creating SS7 instance
<001d> sccp_user.c:397 msc-0: Using SS7 instance 0, pc:0.23.3
<001d> sccp_user.c:411 msc-0: Creating AS instance
<001d> sccp_user.c:421 msc-0: Using AS instance as-clnt-msc-0
<001d> sccp_user.c:426 msc-0: Creating default route
<001d> sccp_user.c:446 msc-0: Creating ASP instance
<001d> sccp_user.c:481 msc-0: Using ASP instance asp-clnt-msc-0
<001d> sccp_user.c:484 msc-0: Creating SCCP instance
<0007> osmo_bsc_sigtran.c:484 (msc-0) A-interface: local (BSC) SCCP address: RI=SSN_PC,PC=0.23.3,SSN=BSSAP
<0007> osmo_bsc_sigtran.c:486 (msc-0) A-interface: remote (MSC) SCCP address: RI=SSN_PC,PC=0.23.1,SSN=BSSAP
<0007> a_reset.c:106 A-RESET(msc-0)[0x55d06a0328e0]{DISC}: (re)sending BSSMAP RESET message…
<0007> osmo_bsc_sigtran.c:92 Sending RESET to MSC: RI=SSN_PC,PC=0.23.1,SSN=BSSAP
<001c> m3ua.c:507 XUA_AS(as-clnt-msc-0)[0x55d06a031b40]{AS_DOWN}: Event AS-TRANSFER.req not permitted
<0007> a_reset.c:106 A-RESET(msc-0)[0x55d06a0328e0]{DISC}: (re)sending BSSMAP RESET message…
<0007> osmo_bsc_sigtran.c:92 Sending RESET to MSC: RI=SSN_PC,PC=0.23.1,SSN=BSSAP
<001c> m3ua.c:507 XUA_AS(as-clnt-msc-0)[0x55d06a031b40]{AS_DOWN}: Event AS-TRANSFER.req not permitted
<0007> a_reset.c:106 A-RESET(msc-0)[0x55d06a0328e0]{DISC}: (re)sending BSSMAP RESET message…
<0007> osmo_bsc_sigtran.c:92 Sending RESET to MSC: RI=SSN_PC,PC=0.23.1,SSN=BSSAP
<001c> m3ua.c:507 XUA_AS(as-clnt-msc-0)[0x55d06a031b40]{AS_DOWN}: Event AS-TRANSFER.req not permitted
^Csignal 2 received
<0004> bsc_init.c:48 shutting down OML for BTS 0

root@murat:/etc/osmocom# osmo-msc
<0011> telnet_interface.c:104 telnet at 127.0.0.1 4254
<000c> smpp_smsc.c:1011 SMPP at 0.0.0.0 2775
<0018> control_if.c:887 CTRL at 127.0.0.1 4255
<001b> gsup_client.c:74 GSUP connecting to 127.0.0.1:4222
<0006> msc_main.c:373 CS7 Instance identifiers: A = Iu = 0
<001e> sccp_user.c:370 OsmoMSC-A-Iu: Creating SS7 instance
<001e> sccp_user.c:397 OsmoMSC-A-Iu: Using SS7 instance 0, pc:0.23.1
<001e> sccp_user.c:411 OsmoMSC-A-Iu: Creating AS instance
<001e> sccp_user.c:421 OsmoMSC-A-Iu: Using AS instance as-clnt-OsmoMSC-A-Iu
<001e> sccp_user.c:426 OsmoMSC-A-Iu: Creating default route
<001e> sccp_user.c:446 OsmoMSC-A-Iu: Creating ASP instance
<001e> sccp_user.c:481 OsmoMSC-A-Iu: Using ASP instance asp-clnt-OsmoMSC-A-Iu
<001e> sccp_user.c:484 OsmoMSC-A-Iu: Creating SCCP instance
<0010> a_iface.c:641 Initializing SCCP connection to stp…
<001b> gsup_client.c:74 GSUP connecting to 127.0.0.1:4222
<001b> gsup_client.c:74 GSUP connecting to 127.0.0.1:4222
<001b> gsup_client.c:74 GSUP connecting to 127.0.0.1:4222
<001b> gsup_client.c:74 GSUP connecting to 127.0.0.1:4222
<001b> gsup_client.c:74 GSUP connecting to 127.0.0.1:4222
<001b> gsup_client.c:74 GSUP connecting to 127.0.0.1:4222
<001b> gsup_client.c:74 GSUP connecting to 127.0.0.1:4222

#12

Okay Now I am running all osmocom applications . osmo-bsc osmo-msc osmo-hlr but I have same problem . I can not see my base station name in phone search . Why Phone is not see ? I write this name in osmo-bsc.cfg but İt is giving error to me ? Please Help ?
network
network country code 286
mobile network code 03
short name tekinbts
long name tekinbts

root@murat:/etc/osmocom# osmo-bsc
logging level cc (everything|debug|info|notice|error|fatal)
logging level mgcp (everything|debug|info|notice|error|fatal)
There is no such command.
Error occurred during reading the below line:
short name tekinbts

<0004> osmo_bsc_main.c:500 Failed to parse the config file: ‘osmo-bsc.cfg’
Bootstrapping the network failed. exiting.

#13

Could you please not spam the forums with so many posts in such a short period of time.

It looks as though you’re not configuring the stack correctly and the best place to get support on this would be the Osmocom community. I’d start by studying their documentation — thoroughly — and then if you still have issues, posting to their mailing list.

https://osmocom.org/projects/cellular-infrastructure

https://lists.osmocom.org/mailman/listinfo/openbsc