Has Anyone Gotten CubicSDR to Run With Their LimeSDR...?

Just wondering if anyone has gotten CubicSDR to run with their LimeSDR…? I’ve been trying A LOT of different ways to have CubicSDR recognize my LimeSDR, but it hasn’t happened…I can’t get CubicSDR to ‘see’ my LimeSDR. I can attach my HF Upconverted RTL-SDR to CubicSDR and it finds it and plays fine. But I’ve yet to get the Lime to work on that app.

Any suggestions from those who have successfully made CubicSDR work with the LimeSDR…? Please do let me know the tricks, if any.

73 de Marty, KN0CK

Same here…
tested only under Win10 64
Using Photos instalation /bin
SDRplay and RTL-SDR working now ok.



DJ - Yeah, I haven’t had any luck getting the :LimeSDR running on my Cubic install at all…Maybe @joshblum may know the reason why.

73 de Marty, KN0CK

I compiled Cubic on my MacMini using the git-version. It recognizes the LimeSDR, but when I click on “Start” Cubic terminates with “Segmentation fault: 11:frowning:

I tracked down the bug. So there was a missing default for some stream arguments. I fixed that in LimeSuite master/stable branch. And posted a bug on Cubic to add some bounds checking: https://github.com/cjcliffe/CubicSDR/issues/534

Any suggestions from those who have successfully made CubicSDR work with the LimeSDR…? Please do let me know the tricks, if any.

I’m not having any issues FWIW, and it looks like the PothosSDR installer was built before that segfault bug was introduced, so it should work. Suggestions:

1 Like


I’m using the Windows version on CubicSDR and just wondering what it takes to include these new changes in the LimeSuite. Is there a recompile I need to do under Windows and if so, do you have the instructions how to do that or is there a new .msi file that will install over the existing LimeSuite?

In both LimeUtil and SoapySDRUtil when I do a --find in a command prompt I am able to see the LimeSDR both ways. But when CubicSDR launches it’s not seeing the Lime. So is there a recompile necessary for the LimeSuite that was installed by the Pothos installer…?

Let me know when you have a chance - thanks,

73 de Marty KN0CK

The current installer doesnt appear to have the segfault issue. So I think this was a recently added feature/bug in cubicsdr in reguards to the crash. So there isnt anything to rebuild. I really don’t know why the LimeSDR is not found for your machine

  • Can you confirm that the installer is the latest from march 2017?
  • And that if you try to manually add a device, is “lime” is listed in the list of modules (in the Add button dialog)?
  • And I guess try to manually add the LimeSDR (also with the add button dialog) to see if that works


Josh - Okay…Better now…With the March release I can see the LimeSDR in CubicSDR, but I’m not sure what (if any) antenna is being selected for the selected LimeSDR. Doesn’t appear to receive anything of substance because I think there’s an antenna selection missing (RX1_W, RX1_L, RX1_H…for now). But I can tune and I hear static out of the speakers and I can select the LimeSDR in the list of Soapy devices. I’m betting that CubicSDR doesn’t have provisions for the antenna selection - I looked all over the user interface and could not find it. Let me know if I’m being ‘thick’ on any of that.

73 de Marty, KN0CK

The RX LNAL path should be selected by default (I believe thats RX1L on the board) So that port should work. I don’t see any reference to antenna selection in CubicSDR source. I didnt expect that, but I suppose that many of the devices dont need it. I suggest leaving a feature request on the issue tracker: https://github.com/cjcliffe/CubicSDR/issues/ That would come in handy.


All good and thanks for the further update. I will lodge a few nuggets at the CubicSDR issue tracker. The gain settings also appear to be an issue, too - - there’s no place to adjust PIA, TIA or LNA gains for the LimeSDR and I’m not so certain that there’s a tuning issue, too. Everytime I tune there is a station that just sits there and it’s in AM when I’m clearly tuned in the 40m amateur radio band in the LSB voice segment of that band.

Thanks again for the earlier suggestions about getting the Lime to work with CubicSDR…More to follow…Stay tuned…

73 de Marty, KN0CK

P.S - I tried the GQRX for Windows that was installed along with the Pothos install package and it’s acting like it did in the February release. Demodulation for Upper and Lower Sideband appear to be reversed (in the 40m band, signals sound like normal voice in Upper Sideband where it should be Lower Sideband and vice versa for the 20m band). Not sure if that’s Alex’s job on that or not, but just letting you know that there’s an issue there, too.

73 de MJW KN0CK

Hi Marty!

Yes! got it working on Windows 10, but only after setting the sample rate at 4 MHz.
The USB3.0 board I’ve got MN18 removed - works super here on FM-stereo 88 - 108 MHz.

Best Regards


1 Like


COOL! I will set my sampling rate to 4 MHz and give it a try, too…I haven’t been able to receive anything of any value, but maybe this nugget of info will help. I tried the 60 MHz sampling rate and CubicSDR crashed. So I’ll try your suggestion because 100 kHz isn’t really helping much…Stay tuned.

73 de Marty, KN0CK

I just started looking at CubicSDR on my laptop. I can manually adjust the sample rate to 8Mhz and still get clean audio.

If you go into settings and deselect automatic gain you get the controls to adjust LNA PGA TIA.

I see no option for antenna. It seems to default to LNAL channel 0. I’ve looked at broadcast FM and some narrow band FM public safety in the 800Mhz range.

I have to play around with this a bit more.

Working OK here.

Receiving NOAA 162.400

1 Like

FM stereo broadcast (50 us de-emphasis - which is common in Europe)
(Station call: Radio538 - The Netherlands)

  • 10 MHz bandwidth
  • Antenna: nothing special… 30cm wire extension - indoor
1 Like

No way to select an antenna so no way to use this without swapping antenna cables. Thing is I saw some screenshots of CubicSDR and there were selectable antenna menus???

Maybe those features come in through SDRPlay or HAMlib or ???


May be that CubicSDR needs to be built with HAMlib. I noticed that it’s optional.

1 Like


You know me too well…I was going to ask about HF…How does one compile what’s there in the Pothos Windows installation…? Lemme know if you have info on that…

73 de Marty, KN0CK

I not long built CubicSDR on an ODROID-C2
25929 root 20 0 2013600 334548 40080 S 182.1 19.0 143:34.81 CubicSDR

There was just one CW signal on 20m using a 1/4 wave sloper not tuned for the band.

The bands are dead, the HiQSDR with the 2-el Lightning Bolt Quad shows no activity.
I’ll see what turns up when 80m is open tonight.
73 … Sid.

Just curious about 182.1% CPU. Is that 182/400 or 182/200?