GSM base station Demo with Limesdr Mini + Raspberry Pi


#1

Any one has test the setup??


#2

any one has test the setup


#3

I am trying to do that as well.

I finished installing LimeSuite and SoapySDR on raspberry pi and make limesdr-mini functional in gnuradio.

But when building UHD, there are errors.


#4

Use this patch from debian package to make uhd compile on armv7

From: A. Maitland Bottoms <bottoms@debian.org>
Subject: debian armhf convert without neon

recent cmake and gcc 6 find arm_neon.h, but
then compilation of convert_with_neon.cpp fails.

--- a/host/lib/convert/CMakeLists.txt
+++ b/host/lib/convert/CMakeLists.txt
@@ -65,18 +65,18 @@
 ########################################################################
 # Check for NEON SIMD headers
 ########################################################################
-IF(CMAKE_COMPILER_IS_GNUCXX)
-    CHECK_INCLUDE_FILE_CXX(arm_neon.h HAVE_ARM_NEON_H)
-ENDIF(CMAKE_COMPILER_IS_GNUCXX)
-
-IF(HAVE_ARM_NEON_H AND (${CMAKE_SIZEOF_VOID_P} EQUAL 4))
-    ENABLE_LANGUAGE(ASM)
-
-    LIBUHD_APPEND_SOURCES(
-        ${CMAKE_CURRENT_SOURCE_DIR}/convert_with_neon.cpp
-        ${CMAKE_CURRENT_SOURCE_DIR}/convert_neon.S
-    )
-ENDIF()
+#IF(CMAKE_COMPILER_IS_GNUCXX)
+#    CHECK_INCLUDE_FILE_CXX(arm_neon.h HAVE_ARM_NEON_H)
+#ENDIF(CMAKE_COMPILER_IS_GNUCXX)
+#
+#IF(HAVE_ARM_NEON_H AND (${CMAKE_SIZEOF_VOID_P} EQUAL 4))
+#    ENABLE_LANGUAGE(ASM)
+#
+#    LIBUHD_APPEND_SOURCES(
+#        ${CMAKE_CURRENT_SOURCE_DIR}/convert_with_neon.cpp
+#        ${CMAKE_CURRENT_SOURCE_DIR}/convert_neon.S
+#    )
+#ENDIF()

 ########################################################################
 # Convert types generation

#5

Thanks. I have now succeeded in compiling uhd, and I can use uhd_find_devices to find limesdr mini on rpi3.

But when compiling openbts, the dependency of libcoredumper keeps causing problem. It says can’t find rule for make clean. Do you have any idea?


#6

Hi SHAO ,can you tell me if you succeed ru gsm base station with limesdr mini
Thanks


#7

Hi,
I’m using OsmoTRX with lms support and a LimeSDR mini and it works perfectly on my laptop computer.
However it looks like the raspberry 3 has not enough CPU power to drive the LimeSDR mini. With 4 samples OsmoBTS stops working saying is not receiving data from the OsmoTRX CLCK interface.
I’ve tried to lower to 1 sample both in tx and rx (apparently it’s forbidden to use a different number of samples for tx and rx) and OsmoTRX continues to run but the BTS doesn’t work, I get no signal.

Do you know any setting to get this to work? I’m using the standard LimeSDR config for OsmoTRX.

Thanks

...
...
trx
  bind-ip 127.0.0.1
  remote-ip 127.0.0.1
  base-port 5700
  egprs disable
  tx-sps 4
  rx-sps 4
  chan 0
    tx-path BAND1
    rx-path LNAW

#8

It’s likely a power supply issue and not CPU related. Remember RPi is only USB 2.0 and in addition to limited current you get with this, we’ve also seen voltage drops due to poor quality cables. Try using a Y-cable.


#9

Thank you very much, I’ve tried and it works like a charm.
I’m not very good in electronics but I’ve read that the raspberry 3 can output a max of 1.2 A from the usb. I’m not using other usb peripherals and I’m not using the ethernet port which (from what I know) drains power from the same source as the usb. So theoretically I could use all the 1.2A for the lime.
I don’t know if this is a problem with current or voltage, but I’ll try with the official raspberry power adapter, it’d be good if I could just attach the card without using a y cable.


#10

I wish that were the case. This will be the maximum for the total of all 4x USB ports, since USB 2.0 standard specifies a maximum of only 0.5A per port. With USB 3.0 it’s nearly double at 0.9A per port.