Faulty LimeSDR?


#1

We recently purchased 2 LimeSDR-USBs at the same time. One works fine as expected after following the instructions. The second appears to be faulty. Upon connecting the board through LimeSuite GUI (in Linux Ubuntu) the following appears:

ERROR: Undefined/Failure
ERROR: Undefined/Failure
ERROR: Undefined/Failure
ERROR: Undefined/Failure
ERROR: Undefined/Failure
ERROR: Undefined/Failure

INFO: Connected Control port: LIMESDR-USB FW:4 HW:4 Protocol: 1 GW:0.0 Ref Clk: -0.0 MHz.

When I attempt to auto program the board, it runs “successfully” but another one line:

ERROR: Undefined/Failure

is returned.

I have closed out of the LimeSuite GUI, run LimeUtil –update, and reopened LimeSuite GUI but still get the message above with the same Ref Clk: -0.0 MHz.

The working LimeSDR has a Ref Clk value, and I am able to run the self.ini and QuickTest on it. Is there something else I should be doing to get the second one to work? Any help would be appreciated. Thank you!


#2

@Zack, any suggestions?


#3

Same problem here:


#4

Hi Michael,

Thank you for your reply. I have tried all the suggestions mentioned in your link to no avail. Still getting the same error…


#5

We are on the same boat, the GW version is always shown as “0”
I was planning to put together a radio box base on LimeSDR. The heatsink, fan, enclosure, cables are sitting on my bench for weeks now but I’m still struggling with this very fundamental issue.
So far from what I can tell (for my board), It’s not a power supply issue, it’s not PC / OS or port related, it’s not fixable by reprogramming. People are trying to help but I’m losing patience with debugging their product, it supposed to be tested before shipping.

I just requested for a replacement yesterday, let’s see how this will be handled

Update:
now I can confirm the issue is temperature related, highly likely a soldering defect.


#6

This issue been coming out lately i have and mine is useless now not even 10 hours usage on it once it plug got hot to 50c not even doing anything yet only thing is after been in storage for few month that when the card got fsked,


#7

Thanks for the update! From the sound of it, I might need a replacement unit as well.


#8

@andrewback, as my issue is similar to @Michael, and we haven’t heard back from @Zack, I believe a replacement unit is in order. Do you agree?


#9

I’m afraid we will need @Zack to confirm we have tried everything possible before arranging an RMA.


#10

Thanks for the quick response. Is there anything we can do to speed this up? Time is of the essence.


#11

So it is a month in and no activity/response. I would like to add that we do have 3 working LimeSDR units (purchased 2 more since the original post) so I would like to think we know how to get the units operational. The lack of feedback on what to do to resolve the issue with the unit that is not working is very concerning.


#12

I’ve only had mine a few days, but my initial efforts failed with similar results to those reported here. I put it down to Windows 10, as I prefer Linux, except for certain things. Good looking SDR software being one of them.

Installation on my other, Linux Mint Tara PC went very smoothly and I was able to run the LimeQuickTest with perfect results. Swap it back to the other PC and no joy again (on Windows 10). So I tried it on a fresh Mint Tara installation on that same PC and it failed the self test. Tailing /var/log/syslog showed the device getting re-initialised, or something like that, which reminded me of what I saw in Windows 10 Device manager while it was on there.

I tried a different USB 3 port and got similar results, but the failures were further on in the self test. Tomorrow I’ll have a USB V/A meter and I’ll see if there are differences there.

Haven’t gone anywhere near connecting an antenna yet. Hoping my first post is helpful. Excuse me if it isn’t.


#13

Add a power supply. I would suggest not to use the USB power meter, as it may hamper throughput.


#14

What’s being done to replace the faulty board that has not worked from day 1? You have had more than enough time to confirm with @Zack about the RMA. I work with sassyn and we cannot move forward without working hardware.


#15

Hi @sassyn,

Arrange RMA with Crowd Supply, please.