Failed to load file when test the limesdr with the self_test.ini

#1

Hi, i got the error when i try to load the self_test.ini following the instruction of https://wiki.myriadrf.org/LimeSDR-USB_Quick_test.

VMWare,Ubuntu 16.04lts

haha@ubuntu~$LimeUtil --info
Version information:
Library version: v17.07.0-g7e9adb76
Build timestamp: 2017-07-14
Interface version: v2017.6.0
Binary interface: 17.07-1

System resources:
Installation root: /usr/local
User home directory: /home/haha
App data directory: /home/haha/.local/share/LimeSuite
Config directory: /home/haha/.limesuite
Image search paths:
- /home/haha/.local/share/LimeSuite/images
- /usr/local/share/LimeSuite/images

Supported connections:

  • PCIEXillybus
  • STREAM
  • uLimeSDR
    haha@ubuntu~$LimeUtil --find
  • [LimeSDR-USB, media=USB 3.0, module=STREAM, addr=1d50:6108, serial=00090620********]

So, Plz help me about this, thx a lot:)
@andrewback

#2

Hi @kevinhong,

Is this board new one?
And what is the error?

#3

Hi @Zack,
I have bought two Limesdr-USB boards(LMS7002M) two weeks ago.

When i had setup the environment of limesdr(such as installing the limesuite, gnuradio, and uhd packages) in Ubuntu, i want to test the limesdr.
I followed the guide of the website: https://wiki.myriadrf.org/LimeSDR-USB_Quick_test.

After wget the self_test.ini and connect the limesdr device, i opened it in the limesuite, then I got the error " Failed to load file", just this message, no other information

#4

Hi,

I guess i’ve the same issue. Did you find out something?

#5

It works for me after installing the correct firmware version for the FPGA.

#6

Hi,

I got the same problem when package/installer only, not building from source code.
But I found if copy self_test.ini into /usr/share/LimeSuite directory, and tell LimeSuite load from this directory, “Failed to load file: LoadConfig() - File not found” popup message will be gone !

#7

New finding - I think it is the directory name problem. If there is any “unicode” in the full directory name like “download” by your local language like Chinese, it will make load ini failed.

1 Like
#8

I have this same problem but only when connecting to the LimeSDR through USB3, through USB2 I can load the self_test.ini without problems.I have the 17.07 HW 1.4 r2.8 rfb, but I’m not entirely sure what version is the FX3 .img I flashed on the device…

#9

I have the exact same problem and I can’t get around it.

#10

Try the latest software:
https://wiki.myriadrf.org/LimeSDR-USB#LimeSuiteGUI
gateware:
http://downloads.myriadrf.org/project/limesuite/17.09/LimeSDR-USB_HW_1.4_r2.10.rbf
and firmware:
http://downloads.myriadrf.org/project/limesuite/17.09/LimeSDR-USB_HW_1.3_r3.0.img

#11

Hi,
I just got the LimeSDR USB and once all the proper driver and software installed without any issue: I tried to do the quick test from Myriad site.
Get the same error as you; as it read the file and write into the LimeSDR with errors and then it give you the error that it fail to load the file.
First file to use for Test: self_test.ini

[11:45:55] ERROR: Write(64 bytes) failed

But, after you press [Ok], you cannot have a proper device info, it is unknown device.

I do a reset (Unplug … Plug in again) redo a img & rbf , close the connection, reset again and then I can see the version.

Is the self_test.ini need to be uft-8 or another character set? or the file is too old for the new version:
Limsdr_Vs

Hope that help someone too, have a great one!

#12

I seemed to be facing the same issue… I’ve built LimeSuite from source on Raspberry Pi 3B and seeing the same error message of

“Failed to load file”

and also

“ERROR: Write(64 bytes) failed”

and the device seemed to be unknown after pressing OK. Serial number could not be detected by my Rpi (tried to perform “LimeUtil --update” but received an error message)

On my pi terminal, got several repeated warning messages after failing to load self_test ini:

(LimeSuiteGUI:1454): Gtk-WARNING **: 23:55:15.099: gtk_widget_size_allocate(): attempt to allocate widget with width -5 and height 23

Does anyone know how to resolve this issue?

My firmware and software are all updated and self_test.ini could load and everything works perfectly when I tried it using windows (not built from source)