Errors setting up older mini and USB

Trying to install two old LimeSDR - one mini, one full USB - neither work properly. Tested with powered USB 3 hub as well.



Have I missed something obvious?

Could you test Mini board using this software and provide result.

Try to update LimeSDR-USB using LimeSuiteGUI from this source.

With both devices LimeQuickTest just returns immediately (yes, run from a command prompt!).

For the LimeSDR-USB and the LimeSuite I see:

[13:09:08] INFO: Disconnected control port
[13:09:40] ERROR: Write(64 bytes) failed
[13:09:40] WARNING: Gateware version mismatch!
Expected gateware version 2, revision 19
But found version 0, revision 0
Follow the FW and FPGA upgrade instructions:
Or run update on the command line: LimeUtil --update

I did note that with LimeSuite the USB device was listed as USB 2.0, despite being plugged into a USB 3.0 port?

Are you using LimeSuiteGUI from my link or from Pothos?
It must be USB3. Are you sure USB cable is proper one?

I do appreciate your comments, Zack.

I’ve tried both of the LimeSuiteGUI and they give the same result. It puzzles me that the LimeQuickTest exits immediately. I’ve tried two computers each with a USB 3 port. I’ve just tried a microSD card reader on my first PC, and it shows write/read speeds of 65.9 and 83.0 MB/s so it is USB 3, and the connectors gave the usual blue insert for USB 3. I’ve also tried a second USB cable on the first PC I tested with.

I should point out that these are early devices (although not otherwise used) and from the original KickStarter offers in both cases.

That should, of course, have been “Crowd Supply”, and not “KickStarter”.

What board versions do you have?
If you execute LimeQuickTest software with no boards connected to PC, does it exit immediately as well?

Board versions:
Mini - v1.1
USB - v1.4s

LimeQuickTest.exe exits immediately with no devices connected.

Looks like there are some problems with your OS. This application was tested by many users and no one complained. Do you have a chance to test it on another machine?

Thanks, Zack. I’ve already tested on two PCs, both running Win-10/64, latest released and patched version. These are quite old Lime boards. What does the message:

Expected gateware version 2, revision 19
But found version 0, revision 0

imply? Does any of this software need to be run as administrator? Could I try a USB 2 port via USB 3.0 powered hub (but not get full speed, of course)?

There must be some solution, I hope!

Just tested on a third PC with the same result. Noted that I could use LimeUtils --update to write 1.27, then use LimeSuite, Programming which gave me 1.28. Running LimeUtils again said 1.28 > 1.27 and refused to write the older firmware, so that behaved as expected. I could then run LimeUtils --update --force to write 1.27, which worked as expected, so there is some communication between PC and the Lime Mini.

Suggestions for where to go from here - I don’t know.

I would like to get this working, but I have now reached the point where it seems not to work - at least the gateware always shows a version of “0”. I would like to return this for replacement or repair, so please advise the procedure. I read elsewhere that requests for RMA are being ignored, so am I now left with a £432 ($568) paperweight? Does nobody care?

So you now have a working LimeSDR Mini, but a LimeSDR USB which is reporting gateware version 0? I’m a little confused and would be good to get clarity.

Yes, that’s right. I supported and bought both the USB and Mini from the start on CrowdSupply, but only recently had the need to use them. I started with the USB and spent a long time trying unsuccessfully to get it working with help here and elsewhere. I then tried the Mini and fortunately it worked right away, so at least I knew that what I had been trying was correct in principle. I now need to get either a working device or my money back.

Thanks for the clarification.

Given the nature of board products and that they are a component and can easily be mishandled — mechanically or electrically — there is a 3 month limited warranty and as a backer of the original campaign, the board must be >2 years old and you should have requested support and determined if an RMA was required long before now. However, we’ll see what we can do. @Zack, could you please advise a course of action.

Thanks for you reply. Yes, I appreciate the time factor, but I was hoping that the app store would materialise and this has taken longer than I expected. In fact the unit is not the bare board, but the boxed unit “LimeSDR with Aluminium Kit”, a complete unit and not a component. I was hoping that it’s a simple firmware incompatibility between current software and the unit’s gate/firmware so that a return would not be necessary, but that doesn’t appear to be the case at the moment.


It looks like there is not enough power from USB. Do you have a chance to test it with external power supply?

Tested with a powered USB 3.0 hub, both with a single cable, and with a split power/data cable as supplied with the unit. In this cased version there is no separate power connector accessible. The unit does appear to program its firmware as a different version is reported after programming (and back again). The gateware always appears to report 0 as the version number.

OK, I think we need to test this.