Error in installing osmo-bts-trx in Raspberry PI 4

#1

Hello
I am trying to install Osmocom NITB setup in Raspberry Pi. I am facing few issues(i have searched THE forum BEFORE posting the topic but could not find any direction) .
1:These are library i am building from sources

  • libosmocore
  • libosmo-abis
  • libosmo-netif
  • openbsc
    After the library is
    Then i am tried with these command

wget http://download.opensuse.org/repositories/network:/osmocom:/latest/Raspbian_9.0/Release.key
sha256sum Release.key
apt-key add Release.key
rm Release.key
echo "deb http://download.opensuse.org/repositories/network:/osmocom:/latest/Raspbian_9.0/ ./" > /etc/apt/sources.list.d/osmocom-latest.list
apt update
---------------------------
then 
apt install osmo-bts-trx
The error message is
------------------------------
The following packages have unmet dependencies:
 osmo-bts-trx : Depends: libosmotrau2 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
-----------
I am unsure why the error is coming where i have build libosmocore and libosmo-abis properly.

2: Then i tried to build from the source 
--------------------
git clone git://git.osmocom.org/osmo-bts
cd osmo-bts
autoreconf -fi
./configure --enable-trx
make
make check
sudo make install
sudo ldconfig -i
---------------------------------------
The library is installed properly. But when i try 
sudo osmo-bts-trx -c osmo-bts.cfg
The error message is :
-------------------
<0012> input/ipaccess.c:720 received ID get from 1801/0/0
osmo-bts-trx: relocation error: osmo-bts-trx: symbol osmo_gsm48_rest_octets_si3_decode version LIBOSMOGSM_1.0 not defined in file libosmogsm.so.12 with link time reference
------------------
Either way i am unable to build osmo-bts-rtx 
Could anyone tell why could be done.
Regards 
Priyasloka
LIMESDR MINI Issues
#2

Hi,

Regarding osmocom’s debian repositories failing, my bet is you messed up your setup somehow. You need to find more information on why libosmotrau cannot be installed (tryi installing it directly), since it’s available in here:
http://download.opensuse.org/repositories/network:/osmocom:/latest/Raspbian_9.0/armhf/libosmotrau2_0.7.0_armhf.deb

Regarding building from source: You are presumably attempting to build osmo-bts-trx master against libraries from “latest” repository, which are not master (that woudl be “nightly” repository) but latest tag releases. So it’s perfectly possible that osmo-bts master is using features from libs not yet available in latest releases. So you need to check out osmo-bts tag “1.0.1” before building if you want to build against latest release.

PS: We plan to have a new bunch of releases for Osmocom related software around this/next week.

#3

@pespin Thanks for your reply. Your comments are useful. I tried the setup in Raspberry Pi 3B+, OS Ubuntu Mate. I have been successful(SMS, voice calls were carried out). Probably I messed up the installation in Raspbian and Raspberry Pi 4. There is no reason if Osmocom setup works perfectly in 3B+ and would not work in RaPi4,4GB.

I would take your insights and try again in Rapi 4.

#4

No, don’t try again. Pi4 is crap. It’s different arch (arm64). Drop it! That is the reason!