[ERROR] avahi_service_browser_new() failed: Bad state

I installed Cubicsdr for listen to fm radio but after lime sdr software failed . Please Help How can I fix this error ? İt cant be see usb3 now. I tried delete limesuite limesuite-dev and installed again it not fixed. I tried delete all of software gnu radio soapy vs vs… and install again it not fixed . Do you know how can I fix this software problem ?

root@kali:~# uhd_find_devices
[INFO] [UHD] linux; GNU C++ version 9.2.1 20191109; Boost_106700; UHD_3.14.1.1-1+b1
[ERROR] avahi_service_browser_new() failed: Bad state

– UHD Device 0

Device Address:
serial: 1D4C3893CE8AAC
addr: 24607:1027
driver: lime
label: LimeSDR Mini [USB 2.0] 1D4C3893CE8AAC
media: USB 2.0
module: FT601
name: LimeSDR Mini
type: soapy


That’s not a LimeSDR Mini issue - that’s an issue with the avahi networking service and it’s likely because there’s a version difference with the dependencies it needs. Try recompiling avahi by itself and ensure it has all the dependencies it needs to function properly.

Hope this helps - 73 de Marty, KN0CK

thanks you I installed avahi services again and fixed