Conflicting libuhd003 vs. libuhd003v5 dependencies


#1

Hi Josh,

I am trying to set up a new laptop to be used with a USRP device. After adding the PPAs I have installed the “gnuradio” package. This installed libgnuradio-uhd3.7.7.1 which depends on libuhd003 (3.8.4). However, I would also like to have the tools from the uhd-host package but this package requires the newer libuhd003v5 (3.8.5), which in turn would remove the libgnuradio-uhd and gnuradio packages.

I also noticed that there is an uhd 3.8.4 package which depend on uhd-host, which is at 3.8.5.

Do we need to rebuild gnuradio or how can we resolve this?

Alex


#2

I guess its time to do a rebuild. UHD 3.9.1 and latest gnuradio tag.


#3

Do you have time to do it or should I try?

I have also talked to Dimitri. He will update gr-osmosdr with Cloud-IQ support when he is back in two weeks time and so I will also start migrating gqrx as discussed in the other thread.


#4

I have just updated both UHD and Gnuradio for wily, vivid, and trusty. Mostly backports, but I had to modify gnuradio trusty to use the older python-wxgtk2.8 (since 3.0 was not available on trusty). UHD has the additional patches as well for the various bugs that I have caught. And Soapy SDR is updated, and I’m in the process of uploading the latest support modules. So it should be cool to rebuild a new gr-osmosdr when its ready.


#5

That’s great, thanks!

I think I will rebuild gr-fcdproplus and gr-osmosdr already now to have them consistent with gnuradio, then I can also start playing with the new gqrx package.


#6

I have started rebuilding gr-fcdproplus and gr-iqbal and it went fine, except for vivid:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 sbuild-build-depends-gr-fcdproplus-dummy : Depends: gnuradio (>= 3.7.8) but it is not going to be installed
                                            Depends: gnuradio-dev (>= 3.7.8) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
apt-get failed.

I don’t know why it fails… The only difference I can see is the package uses a different naming convention. Perhaps one has to follow the same naming convention?


#7

The verbose isnt very helpful. I tried this on a vivid machine, it turns out there is a conflicts line “Conflicts: gnuradio (<3.7.8-3)”, well on vivid I used backportpackage… “gnuradio - 3.7.8-3~ubuntu15.04.1myriadrf1”. Somehow that fails the comparison check.


#8

@csete Should be ok now. And I rebuilt the failed packages.


#9

Hi Josh,

Great news, thanks! I have also rebuilt the gr-osmosdr packages to have them consistent with the rest. I used the sources and the debian/ files from the previous package so I assume that soapysdr support is as it should be.