Cant reach of 60MHz of bandwidth

Hi there
I am using limesdr usb version and I need to view I/Q signals at 60MHz bw around 2440MHz. I tried with several sample rates but couldnt manage to reach over 30MHz. How can I overcome this problem? Thanks for any help

Can you confirm that your LimeSDR is being correctly detected as being on USB3. Sometimes it can fall back to USB2 even if plugged into USB3 port. I have seen this happen before. Please check it with latest Limesuite GUI to confirm that it is being detected on USB3. ALSO, please make sure that you have updated to the latest firmware/gateware as this has been known to resolve some USB3 problems too. Let us know how you go.

Kindest regards,
Brendan Jenkins,

I have been able to achieve 60MHz sampling on a Core i5 on USB3 without any problems with the latest firmware/gateware. Windows 7 x64 based system.

Hi Brendan thanks for the reply. Its USB 3.0 On gnuradio I cant see 60mhz bandwidth on fft sink even if I set the bandwidth to 60 mhz I also checked from osmocom fft viewer. The results were the same.

You didn’t specify your computer, maybe it can’t handle processing that many samples. I would try to decrease FFT size in ‘FFT Sink’ block and play a little with “performance vs latency” setting in LMS7 plugin. Or, apply the simplest test: check it with another powerful computer, if you got access to any of that kind.

Sorry to mention about it. I have intel i7 7700HQ 2.8Ghz cpu 16gb ram on a dell laptop with ubuntu16.04 OS

Always check that hardware decrimation in the fpga is set to only 2 at max (160 MHz from the AD/ decrimation Factor). I once had it sitting at 8 and was wondering why i can’t get the bandwidth over 20 MHz.

How can I check that?

My favor test of bandwith is running CubicSDR 2.2 on default 65 MHz, under Ubuntu 16 or 17…
Please try that. Than let us know.

I tried with different samp rates starting from 50 to 60mhz. the program was ok at 56mhz but gave an error at 58mhz. Is it because of the internal filters in the limesdr? I still have 4mhz bandwidth loss Here is the photo

Still couldnt manage to get 60mhz and also bandwidth on the osmocom fft viewer cant exceed 40mhz but on gnuradio I can see max 56mhz