Bts | chan 0 recv buffer of len 2500 expect

i have succesfull created a GSM BTS , however i came around couple of errors which i didnt know what cause them.
and i have couple of questions .

when running osmo-trx-lms some time (lots of time ) its throws thousand lines like this one
<0002> LMSDevice.cpp:544 [tid=139874231457536] chan 0 recv buffer of len 2500 expect 1df8bac got 1e082b4 (1e082b4) diff=f708

<0002> LMSDevice.cpp:544 [tid=140201128675072] chan 0 recv buffer of len 2500 expect 9437b9c got 9440b0c (9440b0c) diff=8f70

when this happen its stop transmiting and the process stop by itself after couple of seconds.
no idea what is the cause of this, id like to know if any one saw see error or what caused it.

2, how to give a name to a BTS ? so when i am scanning with a phone i can see a name like other networks around me ?

i thought
short name LimeSDR
long name LimeSDR
will be it but its not.

the name i see is the ncc+mnc and 2G

the limesdr, as u know there is 2 tx and rx , how do i open two bts on each of the tx/rx ?


Alert which you seen is output of this code

if (timestamp != (TIMESTAMP)rx_metadata.timestamp)
LOGC(DDEV, ALERT) << "chan "<< i << " recv buffer of len " << rc << " expect " << std::hex << timestamp << " got " << std::hex << (TIMESTAMP)rx_metadata.timestamp << " (" << std::hex << rx_metadata.timestamp <<") diff=" << rx_metadata.timestamp - timestamp;


This mean, osmo-trx expected timestamp of first sample in rx buffer 1df8bac, but got 1e082b4. This could indicate the loss of samples.

Do you have enough computing power?
Do you use USB3 to connect computer and LimeSDR?

thanks !
it is connected via usb3.
16gb ram and 2 cpu (+ x2 threads ) in a vm ( the cpu is E5 2650 V4) , ubuntu 18

how come this is not enough :open_mouth: ?

i mean , some ppl had make it work on a raspberry pi (which as less hardware that i provided to the vm)

CPU looks good, but do I understand correctly that you use a virtual machine?
What is native (host) OS?
Could you try it with native Linux and compare it with vm?
2) Name of network is set by conf. in OsmoMSC

mm info 1
short name OsmoMSC
long name OsmoMSC

this is right , i am using a vm.
Ubuntu 18.04 is installed.

the host is windows 10.

this is what i thought
short name Lime
long name Lime

however it does not show the name “Lime” . (it shoes the ncc+mnc and 2G example “63102 2G”)
(i checked with at least 2 phones and 4 sim modems)

new question
how do i setup CRO dB ? ( Cell Reselect Offset)

I’m afraid VM causes your troubles.
I tried OsmoBTS with VM in the past but then I dismissed it because of poor USB bridge performance.

Are you sure you have set mm info 1 ?
Communication with high error rate may cause it too.
Do you use Osmo-nitb or classic Osmo architecture?
Do you have registered SIM in HLR or use open mode?
I tested it with classic Osmo, registered sysmocom SIM on old Nokia 3510 and PLS8-E and name worked with it. But some other cell. modules showes only PLMN, they probably have internal PLMN table with known operators or something else.

I’m sorry I never tried it.


i even tried an unknown ncc

i am running osmo-nitb , osmo-bts-trx , osmo-trx-lms

i have not restricted any SIM in the HLR.
i have tried like 3 different providers and when scanning the cell (manually) its open for everyone, everyone can join (and made sure everyone can join, by joining them manually).
about the PLMN, i also tried a known (a real) ncc and mnc . same thing, no name that i set.

here an example , i set up as the ncc and mnc to 208 10 with name Lime, however! it show me the SFR.


see where issue is reported upstream.

So far in my case LimeSDR failing with osmo-trx seems related to somehow the kernel allocating all the memory in my system, at which point it starts failing (and the error lines reported here are printed). If someboy else can validate same issue with memory allocation (in the kernel, not in the osmo-trx process) that would be great.

actually , i did check that post.
and other posts online, with the same error.

i did check the virtual memory and it was not the issue.
some times after 10sec of me running it , it started to show me this error.
some time 5 sec, and some times 20 min.

i did notice an unusual event when the error occurred , u know the sound when u plug and unplug a device from the usb? i am able to hear that sound when this error occurres. its seems like when the limesdr gets overloaded this happen. but i am not to sure.
i have done like 2-3 tests , i have GOIP modem device with like 32 sim slot , the test i have done were to create a BTS where those sims are suppose to connect to that BTS (i have put the exact mmc mcc for them to connect to me (they did not just for the record :smiley: , i had to done that automaticly.) )
now when i turned on the GOIP device (with 20~ sims connected to it) couple of sec later the limesdr gets disconnected from the vm and reconnects automaticly . and the error occures .

when checking memory allocation all seems right. i even gave my vm 16gb just to make sure.

since we are here, got any idea how to setup CRO ? or set 2 BTS on one limesdr (since there is 2tx 2rx…)