80Mhz bandwidth spectrogram on LimeSDR-mini

Hi
I have tested on Ubuntu 20 and indeed there is some problem. I dont plan to investigate this anytime soon, so i would suggest you to use Ubuntu 18.

Best!

Sorry i did not see your reply sooner. Still i dont understand what is the problem…If you use the “spectrogram” script all flashing is automatic and correct.

is the ‘pip3 install spectrogram’ any different then the ‘pip install spectrogram’?
i mean i know pip3 installs to ~/.local/bin but is one for the rpi3 and one for x86_64?

i did install 18.04.5 and 18.10 (had to enable an old repo as nothing would update in apt).
neither worked. same errors as posted above with 20.04.

i been using ./local/bin/spectrogram --server_only and then connecting either from the laptop connected directly to the limesdr-mini over usb port or i connect over the network with another laptop but either way i use gqrx with these device arguments: soapy=0,driver=remote,remote:driver=lime
i then set gqrx device settings to 80msps and 80mhz bandwidth with 512fft and 60fps and no demodulator.

the spectrogram display i dont believe is acting correctly.
this is all on both laptops running identical installs of ubuntu 20.04 fully updated and with the ‘pip3 install spectrogram’

i would like to try ./spectrogram --server_only and then get it working without gqrx as i not sure how to do this exactly.
i did read the demo notebook but dont really understand matplot to good.

for example i can see 80mhz of spectrum in the display but when i move a logitech mouse that puts out a 2.405mhz signal but that same signal is changing the whole 80mhz wide spectrum when it should just be showing up in one little area of the spectrum.
i might make a little video maybe to show it.
this is when i set the center frequency to 2440mhz like you do in your picture.
so the display shows from 2400 to 2480 spectrum and the 2405mhz mouse signal should show up all the way to the left side of screen when i move it physically.
instead the whole signal (spectrum) is affected when i move the mouse (from 2400 to 2480).
so i know im doing something wrong. :slight_smile:


i was talking in video but i dont hear it when i play it.
when im move my logitech wireless mouse it Tx at 2,405,000,000hz but its spread over the whole spectrum instead of where it is supposed to be.
when i move mouse left to right along the spectra it make alot of little peaks. you can see if you looks close. anyhow do i have a setting wrong or something?

i wanted to say this did work on my raspberry pi 3b running raspberry pi os 2020-08-20-raspios-buster-armhf.zip

i do have a problem with my board appears with that mcu error 5 Rx calibration.

here is my output after i did a clean install then updated and then installed spectrogram

pi@raspberrypi:~ $ spectrogram
2020-10-15 18:39:19.578 | WARNING | main:warn_temperature:16 - Cool your LimeSDR or risk damage!
2020-10-15 18:39:21.875 | INFO | main:docker_pull:20 - Pulling latest docker image…
Error response from daemon: Get https://registry-1.docker.io/v2/: dial tcp: lookup registry-1.docker.io on 8.8.8.8:53: dial udp 8.8.8.8:53: connect: network is unreachable
2020-10-15 18:39:22.180 | INFO | main:probe_devices:83 - Probing for LimeSDR-Mini devices…
2020-10-15 18:39:31.505 | INFO | main:probe_devices:106 - remote_available=False, local_available=True, local_fpga_ok=True
2020-10-15 18:39:31.507 | INFO | main:docker_start_server_daemon:58 - Starting server daemon…
8e3dde5dbdd892667ce8f92e4d80b071d3da4e938f1f1459ed095160bd8906bc
2020-10-15 18:39:34.804 | INFO | main:docker_start_gqrx:48 - Starting gqrx…
2020-10-15 18:39:34.806 | WARNING | main:warn_temperature:16 - Cool your LimeSDR or risk damage!

  • Starting system message bus dbus
    …done.
  • Starting Avahi mDNS/DNS-SD Daemon avahi-daemon
    …done.
    QStandardPaths: error creating runtime directory /tmp/runtime-root: No such file or directory
    libEGL warning: DRI2: failed to authenticate
    [INFO] Make connection: ‘LimeSDR Mini [USB 2.0] 1D3BD0C4F0CDFF’
    [WARNING] This version of LimeSuite only works for the ‘spectrogram’ application!
    [INFO] Device name: LimeSDR-Mini
    [INFO] Reference: 40 MHz
    [INFO] Selected TX path: Band 2
    [INFO] Selected RX path: LNAW
    [INFO] LMS7002M calibration values caching Enable
    setting samples rates to 80 Msps…
    [INFO] Setting oversampling of 2
    [INFO] Selected RX path: LNAH
    [INFO] Setting oversampling of 2
    [INFO] RX LPF configured
    [INFO] SoapyRemote::setupRxStream(remoteFormat=CS16, localFormat=CS16, scaleFactor=2048, mtu=2120, window=44040192)
    [INFO] Server side stream bound to [::ffff:172.17.0.1]:44507
    [WARNING] StreamEndpoint resize socket buffer: set 43008 KiB, got 176 KiB
    [INFO] Configured sender endpoint: dgram=2072 bytes, 512 elements @ 4 bytes, window=176 KiB
    [WARNING] StreamEndpoint resize socket buffer: set 43008 KiB, got 176 KiB
    [INFO] Configured receiver endpoint: dgram=2072 bytes, 512 elements @ 4 bytes, window=176 KiB
    [INFO] Selected RX path: LNAH
    [INFO] Selected RX path: LNAH
    [INFO] RX LPF configured
    [INFO] Selected RX path: LNAW
    [INFO] Selected RX path: LNAH
    [INFO] Selected RX path: LNAH
    [ERROR] Rx calibration: MCU error 5 (Loopback signal weak: not connected/insufficient gain?)
    2020-10-15 18:42:06.547 | INFO | main:main:167 - Killing local server…
    spectrogram_server
    2020-10-15 18:42:08.191 | INFO | main:main:170 - Done!
    pi@raspberrypi:~ $

it does appear to be running ok but what about that error?
i wish i could get ‘spectrogram --server_only’ to work over wifi/lan from rpi3b to my laptops running ubuntu amd64 desktop 18.04/20.4 but no luck so far.
good to see it does work straight out the box with rpi3b and latest raspberry os as of today.
just keep limesdr-mini cool. mine was running at 26C but i have big heat sink and a house fan on it :slight_smile:
@andrewback

One for @Zack.

I don’t know whether you have a software/configuration problem, but this aside something to bear in mind is that RPi 3B USB will be shared between LimeSDR Mini and Ethernet, since the latter is connected to the same bus on the Pi. So generally speaking using both of these together at high data rates is a bad idea. That said, in this case the FPGA is doing FFT and so not as much data should be sent over LimeSDR Mini USB, or indeed network. Though no idea what the actual rates are…

1 Like

to get back on topic about spectrogram.

“2020-08-20-raspios-buster-armhf.img” on my rpi3b works perfect. (Great job Gasparka!)

now for x86_64 hardware im having alot of trouble!
i have tried the following flavors of ubuntu desktop amd64:

focal-desktop-amd64 .iso = ubuntu 20.04 daily
live-image-amd64.hybrid.iso = a person here made this image.
ubuntu-19.10-desktop-amd64.iso
ubuntu-18.10-desktop-amd64.iso
ubuntu-18.04.5-desktop-amd64.iso
ubuntu-18.04.2-desktop-amd64.iso
ubuntu-18.04.1-desktop-amd64.iso
ubuntu-16.04.7-desktop-amd64.iso

all these images i downloaded and flashed to my usb stick.
i then tried them in live enviroment and yes i did install each one. (getting pretty fast at it)
after i did a full install to ssd i then stopped auto updater from updating to next point release and stopped major lts release.
the closest i can get to when spectrogram was published here in this thread and on git was ubuntu 18.04.1 for sept 18 2018 when spectrogram 1.0 was released so i installed the os that was installed at that time.

i cant get it to work. can someone help me install an ubuntu desktop amd64 version that will complete the ‘pip install spectrogram’ and then actually work when invoking ‘spectrogram’ and it not get errors.

with the pi3b it works perfect from the fresh install of raspberrypios to installing ‘pip install spectrogram’ and from running ‘spectrogram’

on ubuntu 18.04.1 amd64 desktop it installs fine i then install spectrogram with ‘pip3 install spectrogram’ since i cant get ‘pip install spectrogram’ to complete.
anyhow after pip3 install spectrogram does complete i get errors and cant start anything.

can someone help me get the regular x86_64 spectrogram to work on ubuntu amd64 desktop?
i can get it to work on pi3b fine. its just a good laptop i cant get it to work on.

There were problems opening GQRX on Ubuntu, this is now fixed!
You need to update your “spectrogram” script from pip:
pip3 install spectrogram --upgrade
Version 1.0.9 should be installed.

1 Like

working great on all my devices.
i have:
I7-4770 laptop (Ubuntu 20.04.1 LTS amd64 Desktop updated)
I3-4005 laptop (Ubuntu 20.04.1 LTS amd64 Desktop updated)
RPI3b 2020–08-20-raspios-buster-armhf

i have tried each device by it self with ‘./spectrogram’ (locally with no network) and it works perfect.
i have also tried running ‘./spectrogram --server_only’ on each device and connected with a remote device with ‘./spectrogram’ and it will find the server and open up gqrx.
sometimes this takes a few times while its probing on the network but it does work.
i connect the devices with my phone wifi hotspot.

everything working good!
make sure to keep the limesdr-mini COOL!

@gasparka great work.
what about spectrogram on android phone? maybe just the server?