Ubuntu 17.04 Zesty not ready?


#21

LimeSuite GUI opens.

First Module FFT viewer- crash

  • You have some obsolete package versions installed. please upgrade the following packages and check if the problem still occurs:

limesuite, limesuite-udev, puthon-soapysdr

I will try to clean this out and reinstall.

Larry in El Paso


#22

There was no Pothos or QSpectrumAnalyzer either

Larry in El Paso


#23

These are in separate repositories. The instructions on the gqrx website installs only what is necessary for gqrx.


#24

There is still something looking for UHD:
Err:22 http://ppa.launchpad.net/ettusresearch/uhd/ubuntu zesty/main amd64 Packages
404 Not Found
This error happened:
Setting up libhackrf0:amd64 (2015.07.2-11) …
rmmod: ERROR: Module hackrf is not currently loaded
I don’t know if these are related:
Segmentation fault (core dumped)
dpkg: error processing package python-openssl (–configure):
subprocess installed post-installation script returned error exit status 239
dpkg: dependency problems prevent configuration of python-ndg-httpsclient:
python-ndg-httpsclient depends on python-openssl; however:
Package python-openssl is not configured yet.

dpkg: error processing package python-ndg-httpsclient (–configure):
dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.

E: Sub-process /usr/bin/dpkg received a segmentation fault.

Larry in El Paso


#25

Larry,

I tested the installation procedure on a freshly installed 17.04 and it worked just fine. I got to the point where gqrx was running. There was a message regarding UHD because the UHD repositories are not available but that’s all.

I can’t help you with the errors you see there, but they do look very serious.

@joshblum I forgot about hackrf initially. Now I have updated it so you may want to rebuild soapyhackrf.


#26

Also, an advice Larry… In case you are using Synaptic package manager, go to Settings -> Preferences and disable the “Consider recommended packages as dependencies” option. This will reduce the amount of unnecessary packages installed.


#27

Thanks again. I changed the preference and reloaded GQRX and now it works.

Larry in El Paso


#28

@joshblum @csete I wondered if you had a summary of packaging updates that I could send to the new list at:

There may only be one or two subscribers at present, but good to get into the habit :slight_smile:


#29

Hi Andrew,

It was basically just an update to support 17.04.


#30

Thanks!


#31

After quite success with LimeSDR on Win10 now I am trying to conquer Ubuntu 17.04 & Lime on another PC :wink:
Keep the fingers crossed…


#32

Some progress, here


#33

CubicSDR & Lime :smiley: