Linux applications for LimeSDR

#1

linhpsdr – git clone https://github.com/g0orx/linhpsdr.git
quisk also runs in RX at the moment - for Linux and Windows
http://james.ahlstrom.name/quisk/index.html
I have a screenshot but can’t see how to attach it.

#2

@sboyce - Sid,

Is the Lime running TX on LinHPSDR, too…? Let me know - I’ll try it along with the HL2…

73 de Marty, KN0CK

#3

Hi Marty,
I have only tested it on RX. I need to connect up for access to TX1.

#4

@sboyce - Sid,

I tried connecting my Lime to LinHPSDR last night as deployed onto a RockPro64 on Ubuntu 18.04 and I have it running on the HL2, but when I connected the Lime to the USB 3.0 port on that RP64 and then launched ‘discover’ on LinHPSDR it didn’t find it. I have Lime resources (SoapySDR, LimeSuite) compiled and running on the board…Wondering if I’m missing anything in the build (like Lime libraries) to have LinHPSDR pick up on it. When you built LinHPSDR what Lime resources did you add as dependencies to LinHPSDR? Greatly appreciate any input on that so I can get my Lime receiving on LinHPSDR, too - then I’ll try transmit. Keep me advised, Sid -

73 de Marty, KN0CK

#5

These are all the packages I have installed from the Ubuntu repos rather than built from sources.
I didn’t set up the PPA as it seemed already accessible but details at
https://wiki.myriadrf.org/Lime_Suite
Make sure you have soapysdr0.6-module-lms7 installed.
root@odroid-n2:~# dpkg -l |grep lime
ii liblimesuite-dev:arm64 17.12.0+dfsg-1 arm64 library to access LMS7 transceiver based hardware (development)
ii liblimesuite17.12-1:arm64 17.12.0+dfsg-1 arm64 library to access LMS7 transceiver based hardware
ii limesuite 17.12.0+dfsg-1 arm64 tools to test, control and update LMS7 transceiver based hardware
ii limesuite-udev 17.12.0+dfsg-1 all Lime Suite - USB rules for udev
root@odroid-n2:~# dpkg -l |grep soapy
ii libsoapysdr-dev:arm64 0.6.1-2 arm64 SoapySDR library development files
ii libsoapysdr0.6:arm64 0.6.1-2 arm64 software defined radio interface library
ii python-soapysdr 0.6.1-2 arm64 SoapySDR Python 2 bindings
ii soapyosmo-common0.6:arm64 0.2.5-1build1 arm64 Use gr-osmosdr drivers with SoapySDR (common files)
ii soapysdr-module-all:arm64 0.6.1-2 arm64 All device support for default version of SoapySDR (metapackage)
ii soapysdr0.6-module-airspy:arm64 0.1.1-1 arm64 Airspy device support for SoapySDR
ii soapysdr0.6-module-all:arm64 0.6.1-2 arm64 All device support for SoapySDR (metapackage)
ii soapysdr0.6-module-audio:arm64 0~git20160607-3build1 arm64 Audio device support for SoapySDR
ii soapysdr0.6-module-bladerf:arm64 0.3.4-1 arm64 bladeRF device support for SoapySDR
ii soapysdr0.6-module-hackrf:arm64 0.3.2-1 arm64 HackRF device support for SoapySDR
ii soapysdr0.6-module-lms7:arm64 17.12.0+dfsg-1 arm64 Lime Microsystems LMS7 device support for SoapySDR
ii soapysdr0.6-module-osmosdr:arm64 0.2.5-1build1 arm64 OsmoSDR device support for SoapySDR
ii soapysdr0.6-module-redpitaya:arm64 0.1.0-2 arm64 RedPitaya device support for SoapySDR
ii soapysdr0.6-module-remote:arm64 0.4.2-1 arm64 Use SoapySDR devices over network (client module)
ii soapysdr0.6-module-rtlsdr:arm64 0.2.4-1 arm64 RTL-SDR device support for SoapySDR
ii soapysdr0.6-module-uhd:arm64 0.3.4-1build1 arm64 UHD device support for SoapySDR
root@odroid-n2:~#
“git clone https://github.com/g0orx/linhpsdr.git” for the latest.
Also make sure “SOAPYSDR_INCLUDE=SOAPYSDR” is uncommented in Makefile, fairly sure it is in the latest.