Host for LimeSDR

USB 2.0 is backward compatible you can used it only in limited bandwidth in tablet pothos dont work i have hp stream 7 pothos wont install let me try install lime card will see if gonna work.

USB 2.0 should work, yes, albeit with significantly reduced data rate and you may well need to use an external power source also, given that it will also supply less current.

I use a Odroid-X2 – its over 5years old and EOL already …
Runs Ubuntu 16.01LTS32bit with USB2 ports … sure bandwidth is reduced … but keeping data on the USB buss down to around 800K/bs seems to work all the time … meaning that using a lower decimation and sample rate does work.

That’s great. Many thanks for the information.

Hi, just few days ago got my Intel Joule 570X developer kit working with the LimeSDR.
The Joule supports USB3, therefore it should be able to use high transfer rates. I have not been able to have Ubuntu Core working yet un the Joule (I am noob) therefore I went for the full Ubuntu install.

It is not an optimized setup but works:

  1. Installed Ubuntu 16.04 as per youtube instructions (https://www.youtube.com/watch?v=xFFG6GR13_4)
  2. Installed “snap”
  3. Followed instructions on “Snap packages for LimeSDR” to add the store to Ubuntu (https://myriadrf.org/blog/snap-packages-limesdr/)
  4. Followed instructions on "Snap packages for LimeSDR"to install all limeade snaps (limesdr-grc, limesdr-pothos, limesdr-gqrx, limesuite).

So far I have succesfully ran:

  1. limesdr-gqrx
  2. limesuite

I will try to get a photo of my setup later…

1 Like

Hardware setting:

  1. LimeSdr
  2. Intel Joule
  3. USB cable / Hub
  4. USB-C to USB
  5. Keyboard
  6. Power supply - not shown
  7. Screen (TV connected via micro HDMI to HDMI cable) - not shown.
2 Likes

LimeSDR + Intel Joule system up…

Limesuite:

Limesuite Gqrx:

I hope this helps…

3 Likes

Nice! Thanks for sharing :slight_smile:

I have had Core running on a Joule:

https://www.rs-online.com/designspark/app-enable-an-embedded-system

However, it looks as though we’ll need to bake our own custom Core images that are tied to one of our app stores and this is something we’re working on now.

@andrewback
Thank you for the information, I believe you are correct about about the custom core…
When I tried to install Ubuntu Core on the Joule I got as far as getting it to boot from the SD card, but my goal was / is to get it to boot from the internal storage (eMMC).

Thank you again.

Thank you so much for sharing. That’s very useful.

Have you had any luck getting limesdr-grc to work? I installed the limesuite and limesdr-gqrx snaps on a fresh installation of Ubuntu 16.04 on a Lenovo T430 laptop, and they both work fine, but limesdr-grc (version 3.7.11.1.0) doesn’t appear to do anything. No window appears; the icon in the launcher disappears after about 15 seconds, and that’s it.

Have I missed something?

Thanks!

@G4GSK
Short answer no, using the snap versions I have the same result with limesdr-grc on the Joule as you are having on your T430.
The only thing I can add at this moment is:
limesdr-pothos starts properly, not done anything beyond it.

This isn’t really standalone mode but I think you can run the LimeSDR on CHIP. You can also run it on an arduino but if you choose to do this, you need to interface directly with the LMS7002 via SPI.

You can program the LMS7002M via SPI with an Arduino, but an ATmega MCU isn’t going to be any use in handling the baseband, nor in fact probably even an ARM MCU-based Arduino.

What about Teensy? It’s much more powerful than arduino and it’s fully compatible? With some work you could even get it working via the USB Host (Teensy supports OTG).

The LMS7002M has a 12-bit DAC and ADC that run at 640MHz and 120MHz respectively. That’s a lot of I/O. You could have an FPGA between this and an MCU, to decimate and interpolate. The LimeSDR has one for this and other purposes. But trying to use an MCU for LMS7002M I/Q is like trying to fill a thimble with a fire hose.

1 Like

Okay, I didn’t know that. Thanks!

@andrewback what do you mean when you say “ATmega MCU isn’t going to be any use in handling the baseband, nor in fact probably even an ARM MCU-based Arduino” my task is to transmit GSM signal having frequency of 942MHZ and i am going to use arduino spi interface with limesdr

What I mean is that you’re not going to be able to connect an ATmega MCU to the LimeLight IQ digital interface and use it for DSP. The SPI interface is just for programming the transceiver and not transferring samples.

Im in the same boat. im on a fresh install of ubuntu server 16. gqrx works, but grc launches and crashes