Faulty LimeSdr Mini

#1

have tested on linux LimeQuickTest --no-gui and with windows on USB 3.0 for both and both tell me faulty device. How do have it replaced??

#2

Post log file here, please.

#3

Windows Log (No USB 3.0)

LimeSDR-Mini_1D40EE3D36AF1C.log
[ TESTING STARTED ]
->Start time: Thu Jun 13 22:29:20 2019

->Device: LimeSDR Mini, media=USB 2, module=FT601, serial=1D40EE3D36AF1C, index=0
Warning: USB3 not available
Serial Number: 1D40EE3D36AF1C

[ Clock Network Test ]
->REF clock test
Test results: 16606; 29803; 43000 - PASSED
->VCTCXO test
Results : 6711036 (min); 6711197 (max) - PASSED
->Clock Network Test PASSED

[ FPGA EEPROM Test ]
->Read EEPROM
->Read data: 12 06 1C 12 06 1C 02
->FPGA EEPROM Test PASSED

[ LMS7002M Test ]
->Perform Registers Test
->External Reset line test
Reg 0x20: Write value 0xFFFD, Read value 0xFFFD
Reg 0x20: value after reset 0x0FFFF
->LMS7002M Test PASSED

[ RF Loopback Test ]
->Configure LMS
SetFrequencySXT(1250 MHz) - cannot deliver frequency
TuneVCO(CGEN) - failed to lock (cmphl!=0)
SetFrequencyCGEN(122.88 MHz) failed
Failed to set sample rate
->RF Loopback Test FAILED

=> Board tests FAILED <=

Elapsed time: 2.79 seconds

Ubuntu 18.04 LTS SERVER (USB 3.0)

[ TESTING STARTED ]
->Start time: Thu Jun 13 14:38:55 2019

->Device: LimeSDR Mini, media=USB 3.0, module=FT601, addr=24607:1027, serial=1D40EE3D36AF1C
Serial Number: 1D40EE3D36AF1C

[ Clock Network Test ]
->REF clock test
Test results: 39596; 52793; 454 - PASSED
->VCTCXO test
Results : 6711046 (min); 6711207 (max) - PASSED
->Clock Network Test PASSED

[ FPGA EEPROM Test ]
->Read EEPROM
->Read data: 12 06 1C 12 06 1C 02
->FPGA EEPROM Test PASSED

[ LMS7002M Test ]
->Perform Registers Test
->External Reset line test
Reg 0x20: Write value 0xFFFD, Read value 0xFFFD
Reg 0x20: value after reset 0x0FFFF
->LMS7002M Test PASSED

[ RF Loopback Test ]
->Configure LMS
SetFrequencySXT(1250 MHz) - cannot deliver frequency
TuneVCO(CGEN) - failed to lock (cmphl!=0)
SetFrequencyCGEN(122.88 MHz) failed
Failed to set sample rate
->RF Loopback Test FAILED

=> Board tests FAILED <=

Elapsed time: 1.88 seconds

By looking at your SCH I noticed you have IC12&IC13 LXDC55KAAA-205 As power Regulators, to save time you think changing one them should solve the issue??

Thank you very much for your help, We are developpers and time frame is a big issue for us.

#4

Hi @smtguide,

Could you run this version of QuickTest on Win machine and post the log file here again, please.

#5

[ TESTING STARTED ]
->Start time: Fri Jun 14 23:05:05 2019

->Device: LimeSDR Mini, media=USB 2, module=FT601, serial=1D40EE3D36AF1C, index=0
Warning: USB3 not available
Serial Number: 1D40EE3D36AF1C

[ Clock Network Test ]
->REF clock test
Test results: 56296; 3957; 17154 - PASSED
->VCTCXO test
Results : 6710997 (min); 6711159 (max) - PASSED
->Clock Network Test PASSED

[ FPGA EEPROM Test ]
->Read EEPROM
->Read data: 12 06 1C 12 06 1C 02
->FPGA EEPROM Test PASSED

[ LMS7002M Test ]
->Perform Registers Test
->External Reset line test
Reg 0x20: Write value 0xFFFD, Read value 0xFFFD
Reg 0x20: value after reset 0x0FFFF
->LMS7002M Test PASSED

[ RF Loopback Test ]
->Configure LMS
TuneVCO(CGEN) - failed to lock (cmphl!=0)
SetFrequencyCGEN(61.44 MHz) failed
TuneVCO(CGEN) - failed to lock (cmphl!=0)
SetFrequencyCGEN(122.88 MHz) failed
Failed to set sample rate
->RF Loopback Test FAILED

=> Board tests FAILED <=

Elapsed time: 2.80 seconds

Ubutnu 16.04 GQRX Test

Loading configuration from: “/home/user/.config/gqrx/default.conf”
Configuration file: “/home/user/.config/gqrx/default.conf”
gr-osmosdr v0.1.x-xxx-xunknown (0.1.5git) gnuradio 3.7.10
built-in source types: file osmosdr fcd rtl rtl_tcp uhd plutosdr miri hackrf bladerf rfspace airspy airspyhf soapy redpitaya
XmbTextListToTextProperty result code -2



No change in output device:
old:
new:

Failed to set RX input rate to 5e+06
Your device may not be working properly.

IQ DCR samp_rate: 5e+06
IQ DCR alpha: 2e-07
Changing NB_RX quad rate: 96000 -> 5e+06
Requested sample rate: 5000000
Actual sample rate : “5000000.000000”
New FFT rate: 25 Hz
Segmentation fault (core dumped)

#6

Hi @smtguide,

It looks like there is a fault in your board, sorry.