Connect to phone


From all my experimentation with a Linux environment running from a rooted smartphone, the rooted environment exists on a shell of the Android OS (kind of like VirtualBox or the like) and the audio stream in that Linux environment is UDP packets unless you can route it out some other way…It takes a UDP player on the Android side that can connect to the UDP port on the Linux side to allow the audio packets to stream to the Android side so they can be processed and played…That was my deterrent (in January) since SDRAngel (at the time) didn’t have provisions to stream the audio out in UDP packets…Since then that’s been fixed and it’s possible to get audio out of the Linux side of a rooted smartphone…Just so you’re aware…I haven’t had time to play with it since January because SDRAngel didn’t apply that fix until May or so - so that’s on my ‘to-do’ list but the issue is still there until I pull down the latest SDRAngel, compile it and then connect up the audio using a UDP player on the Android side…

73 de Marty, KN0CK

If I can see the device being opened and closed on that Linux environment, it means I can theoretically send PCM data straight to it, without going circles using protoplayer, UDP player or pulsedroid.
And this is what I see after running alsactl monitor and playing back something on android - the above devices opening and on a time-out closing.
The thing is, pulseaudio works in a different manner to alsa, so I’m not sure how to make the device visible there.

The Pulseaudio server can run in the chroot, but you have to disable the Android sound system, because it will try to keep the audio device open and either Android or Pulseaudio will crash.
To disable the Android audio system temporarily, this resource might be useful to you:

The mixer_paths.xml also contains the paths you need to enable before having sound in Pulseaudio. You can use tinymix to do that from the chroot. If you rename this file and then make a new copy disabling the active paths, Linux audio will no longer have a conflict. I’ll try to attach the tinymix settings I used, but they might be different between phones, so you should look into your Android config as well.